VirtualBox

Opened 15 years ago

Closed 15 years ago

#4029 closed defect (duplicate)

FreeBSD 6.4 guest on MacOS 10.5.7 host has severe ATA emulation problems with firewire hard disks

Reported by: Christoph Sold Owned by:
Component: virtual disk Version: VirtualBox 2.2.2
Keywords: Cc:
Guest type: BSD Host type: Mac OS X

Description

Compiling world in FreeBSD 6.4 guest makes the virtual machine completely unresponsive. even logging on the console does not work, spawning processes is no long possible. Lots of "g_vfs_done():ad0s1d[WRITE(<offset>, <length>)]error = 6" messages on console with various offsets and lengths (see screen shot) pop up on the guest console before the virtual machine freezes. Host configuration: Mac OS X 10.5.7, virtual disk on external hard disk connected via firewire. VBox.log as well as Screen shot attached.

Attachments (2)

VBox-FreeBSD6.4-frozen.gif (29.1 KB ) - added by Christoph Sold 15 years ago.
Screen shot of frozen guest console
VBox.log (34.7 KB ) - added by Christoph Sold 15 years ago.
VBox.log (machine still running, guest is still frozen)

Download all attachments as: .zip

Change History (8)

by Christoph Sold, 15 years ago

Attachment: VBox-FreeBSD6.4-frozen.gif added

Screen shot of frozen guest console

by Christoph Sold, 15 years ago

Attachment: VBox.log added

VBox.log (machine still running, guest is still frozen)

comment:1 by warchild, 15 years ago

http://forums.virtualbox.org/viewtopic.php?f=8&t=18074&p=78137#p78137

Iam receiving the same, I find it only happens when I create a lot of disk access.

thanks

comment:2 by aeichner, 15 years ago

Issue looks like #2524. Can you try if the mentioned workaround works for you please?

in reply to:  2 comment:3 by Christoph Sold, 15 years ago

Replying to aeichner:

Issue looks like #2524. Can you try if the mentioned workaround works for you please?

As in "11.2.1 Windows boot failures (bluescreens) after changing VM configuration ... Most importantly, never disable ACPI and the I/O APIC if they were enabled at installation time."?

Never changed the IO APIC settings (yet). Default settings where ACPI on, I/O APIC off. Will repeat the test in a new VM with different settings tonight.

comment:4 by warchild, 15 years ago

I have tried it, I set the size to 10mb's and so far so good.

Thanks

comment:5 by Christoph Sold, 15 years ago

Ooops... never debug early in the morning. Scrap my last statement, will try tomorrow.

comment:6 by Frank Mehnert, 15 years ago

Resolution: duplicate
Status: newclosed

So I will close this one as duplicate of #2524.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use