VirtualBox

Ticket #4010 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Shared folder not showing all files. Files missing

Reported by: zaita Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.2.2 Keywords: missing files
Cc: Guest type: Windows
Host type: other

Description

I have a shared folder that will not display most of the files in the folder if the files in that folder number 32 or higher. It doesn't matter whats in the 32nd file. But 22 files will go missing along with folders etc.

Screenshot attached so the same folder accessed 2 different ways. Unfortunately, I can only use Shared folders when Cisco VPN is running.

Host and Guest are Both Windows XP Pro 32bit SP3.

Attachments

BugScreenshot.jpg Download (168.7 KB) - added by zaita 5 years ago.
Vbox.log Download (31.6 KB) - added by zaita 5 years ago.
vb_problem.jpg Download (227.6 KB) - added by spocklw 5 years ago.
VBox.log Download (46.9 KB) - added by spocklw 5 years ago.
VBox2.log Download (51.3 KB) - added by spocklw 5 years ago.
20090126152147_2.zip Download (118.9 KB) - added by JohnSpray 5 years ago.
Folder to reproduce problem
hostdir.txt Download (1.8 KB) - added by JohnSpray 5 years ago.
guestdir.txt Download (357 bytes) - added by JohnSpray 5 years ago.

Change History

Changed 5 years ago by zaita

comment:1 in reply to: ↑ description Changed 5 years ago by zaita

To clarify. With Cisco VPN running. Shared folders is the only method to access files outside of the VM. Cisco over-rides all networking. So I can't access it via network share.

comment:2 Changed 5 years ago by frank

A VBox.log file would be interesting though. Which host is that?

Changed 5 years ago by zaita

comment:3 Changed 5 years ago by zaita

Host: Windows XP 32bit Professional SP3

comment:4 Changed 5 years ago by spocklw

I'm experiencing the same problem, only my guest system will only display 28 items. VirtualBox version 2.2.4-1 My host system is ArchLinux, current kernel 2.6.29.4-1, guest system is Windows XP. Screenshot and log attached.

Changed 5 years ago by spocklw

Changed 5 years ago by spocklw

comment:5 Changed 5 years ago by spocklw

However some other folders are displying me more than 100 files so I'm not sure what the problem is.

comment:6 Changed 5 years ago by spocklw

Ok, other thing - when I deleted one of the displayed folders in impacted mapped folder, all of sudden it started displaying all files correctly. I'm attaching a log when this happened, hopefully it will help you.

Changed 5 years ago by spocklw

comment:7 Changed 5 years ago by zaita

spocklw has very similar symptoms to myself.

Unfortunately I've had to swap to using Offline folders in the meantime as having folders go missing really screws up the source-control commits. It's a work around, a bit more hassle and more time required to continually sync. But it's usable if you need access.

Changed 5 years ago by JohnSpray

Folder to reproduce problem

comment:8 Changed 5 years ago by JohnSpray

I attached a folder of 24 small files that reproduces the problem, at least for me. The only necessary conditions I know of is to just share this folder. In the guest, only the last file of the folder is there.

It seems to relate to the total number of characters in the filenames of the folder. If you rename any of the first 23 files to be 1 character longer or one character shorter, then all 24 files will appear in the guest. If you rename two files, but keep the total of their lengths the same, then the problem persists. (Avoid renaming a file such that its order changes to be after the last file though, or the problem will go away.)

I'm using a Vista64 host and Windows XP SP3 guest. I've had this problem on occasion for many versions now, including pre 2.0.)

comment:9 Changed 5 years ago by sunlover

Thanks, JohnSpray. We'll try to reproduce the problem.

comment:10 Changed 5 years ago by sunlover

JohnSpray, could you please add output of a 'dir' command for this directory on the host and in the guest? Thanks.

Changed 5 years ago by JohnSpray

Changed 5 years ago by JohnSpray

comment:11 Changed 4 years ago by quotequad

I have the same problem on v3.0.12. Strangely, if I open up a DOS window and type dir, all files appear.

comment:12 Changed 4 years ago by frank

quotequad, no VBox.log file attached. Which version of the guest additions do you have installed in your guest?

comment:13 Changed 4 years ago by quotequad

Ah, thanks. Old VM image, so old guest additions. Updated and everything is fine. Thanks again.

comment:14 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. I will close this ticket as the problem should be solved with VBox 3.0.12.

comment:15 Changed 4 years ago by JohnSpray

Confirm issue solved.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use