VirtualBox

Ticket #4000 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Abort VBox upgrade if at least one VM is running or paused

Reported by: teratorn Owned by:
Priority: major Component: VM control
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I often used Ctrl-P to toggled the "paused" state of a Windows XP VM (Linux host).

This has always worked great, however today I upgraded to 2.2.2 (r46594).

The next time I tried to unpause the VM (it had been paused for many hours) an error dialog came up "Unable to resume execution..." with the error Callee RC: NS_ERROR_ABORT (0x80004004)

This results in an aborted VM and loss of execution state... not fun :(

OS: Ubuntu 8.10 $ apt-cache policy virtualbox-2.2 virtualbox-2.2:

Installed: 2.2.2-46594_Ubuntu_intrepid

...

I've attached the log for this

Attachments

VBox.log Download (37.0 KB) - added by teratorn 5 years ago.

Change History

Changed 5 years ago by teratorn

comment:1 Changed 5 years ago by teratorn

I have a strong hunch that this has something to do with the package upgrade procedure leaving the Virtual Box kernel componenets and/or the userland daemons (VBoxSVC, VBoxXPCOMIPCD) in a bad state.

Immediately after this error occured I closed the Virtual Box GUI, but the process remained and prevented me from launching the GUI again. After killing this process I tried to start the GUI again and still it wouldn't start... the process was running but appeared to be hanging at some point.

A reboot fixed it and pause/resume appears to be working normally, at least the couple of times that I tried it.

comment:2 Changed 5 years ago by frank

When did you do the upgrade? Are you 100% sure that no VM was running?

comment:3 Changed 5 years ago by teratorn

It's possible that the VM was running when I did the upgrade.. I don't think so but I can't rule it out 100%.

Regardless, if the package can't be upgraded with VirtualBox running then a 'preinst' script ought to detect that an abort with an error.

comment:4 Changed 5 years ago by frank

  • Summary changed from Attempting to resume paused VM: Callee RC: NS_ERROR_ABORT (0x80004004) to Abort VBox upgrade if at least one VM is running or paused

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Since VBox 3.0.6 the Linux packages check if there is an active VM and refuse to install.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use