VirtualBox

Ticket #399 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Problem with removing of shared folder

Reported by: moonlight Owned by:
Priority: major Component: other
Version: VirtualBox 1.4.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Host: Ubuntu 7.04

To reproduce:
1 Create folder and make it shared (VBoxManage sharedfolder add)
2 Unregister shared folder (VBoxManage sharedfolder remove)
3 Remove ex-shared folder from host
Result:
vm becomes inaccessible (recovers if restore folder on host)

Change History

comment:1 Changed 7 years ago by michael

I was unable to reproduce this. Was the VM running at the time? In a saved state? Could you give a more exact sequence of events (including the command lines you used)?

comment:2 Changed 7 years ago by moonlight

Try to experiment with this script. It causes very strange effects sometimes

#!/bin/sh

VM_NAME=Core

cd /opt/VirtualBox-1.4.0/

mkdir /tmp/test1
./VBoxManage sharedfolder add $VM_NAME -name my_share -hostpath /tmp/test1
./VBoxManage startvm $VM_NAME &
sleep 150 # Boot guest, attach share, write something
./VBoxManage controlvm $VM_NAME poweroff
sleep 5
./VBoxManage sharedfolder remove $VM_NAME -name my_share
rm -R /tmp/test1
mkdir /tmp/test2
./VBoxManage sharedfolder add $VM_NAME -name my_share -hostpath /tmp/test2
./VBoxManage startvm $VM_NAME


./VBoxManage sharedfolder remove $VM_NAME -name my_share
rm -R /tmp/test1
rm -R /tmp/test2

comment:3 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use