VirtualBox

Ticket #3973 (closed defect: fixed)

Opened 5 years ago

Last modified 16 months ago

OS/2 guest cannot shut down if guest additions are installed

Reported by: madbrain Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: all

Description (last modified by michaln) (diff)

I did a fresh install of OS/2 ACP2 in a VM. Before installing the guest additions, I was able to shut it down, using right-click on desktop, and "shutdown" option.

After installing the OS/2 guest additions, it doesn't work anymore. The OS never shuts down. The only way is to CTRL-ALT-DEL, which flushes the file system, but isn't as clean.

Note that my OS/2 install was fairly basic, it included only TCP/IP for networking, but not file & print sharing (ie. no lan server) which is known to sometimes cause problems/delays in OS/2 shutdown.

I have narrowed down this problem to the vbox guest extensions.

Change History

comment:1 Changed 5 years ago by armandckj

This defect is also present on Virtualbox 2.1.2 with Mac OSX 10.4.11 host.

Solution: OS/2 Warp 4.0 with Fp15 and IBMSDD sdd driver. Make the changes to config.sys. Do not put the ddl files in \os2\dll. This way vboxguest.exe will not execute (cannot find lib*.dll) in startup.cmd.

After a restart mouse and keyboard integration work. I do not know what vboxguest.exe would add for function. Please try this for 2.2.2

Regards, Armand

comment:2 Changed 5 years ago by david__schmidt

I verified on 2.2.4, OSX 10.5, OS/2 guest, not running vboxguest.exe cures the shutdown problem. The only change I made was to comment out vboxguest.exe from my startup.cmd - I didn't change anything in config.sys.

comment:3 Changed 16 months ago by michaln

  • Status changed from new to closed
  • Host type changed from Windows to all
  • Resolution set to fixed
  • Description modified (diff)

Yes, this was caused by the VBoxGuest.exe daemon preventing shutdown. This should be fixed as of VirtualBox 4.2.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use