VirtualBox

Ticket #3972 (reopened defect)

Opened 7 years ago

Last modified 2 weeks ago

OS/2 guest cannot write to floppy disk

Reported by: madbrain Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by aeichner) (diff)

I am using a Vista x64 SP2 host, and OS/2 ACP2 guest. When I mount the floppy drive in the guest, I can read files from the floppy just fine. But I can't do any writes. All writes (such as COPY, DEL, etc) result in a SYS0039 "The A: device is not ready".

The floppy drive works fine in the host, and I am able to do those same operations in the host OS to the same floppy disk just fine (if I unmount the floppy from the guest, of course).

Attachments

VBox.2.log Download (48.3 KB) - added by madbrain 7 years ago.

Change History

Changed 7 years ago by madbrain

comment:1 Changed 2 weeks ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

comment:2 Changed 2 weeks ago by madbrain76

I just tested it again with Virtualbox 5.0.26 r108824, which I believe is the current release. Host is now Windows 10 x64.

The physical floppy drive is a USB floppy.

But the problem is still the same as it was 7 years ago. I can read from the floppy in OS/2, but I can't write to it.

I now get SYS0021: the drive is not ready.

rather than SYS0039:

but this maybe because the OS is OS/2 ECS 2.1 vs OS/2 ACP2.

Still, the symptom is the same.

comment:3 Changed 2 weeks ago by madbrain76

  • Status changed from closed to reopened
  • Resolution obsolete deleted
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use