VirtualBox

Ticket #3965 (closed defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

Windows XP crashes (BSOD) when clicking shortcut to non-existant shared folder

Reported by: myxiplx Owned by:
Priority: critical Component: shared folders
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

A long while ago I created a link to a VirtualBox shared folder, and placed that shortcut to it in the toolbar next to my start menu. Today I clicked on that link, and my computer crashed.

  • The first time it crashed, Virtualbox shrunk to a single line of colourful dots.
  • After I rebooted, I right-clicked on the icon to delete it, that blue screened windows.
  • After the next reboot, I created a new toolbar, planning to move the icon somewhere safe out of the way, dragging the icon caused another blue screen.

The blue screen only appears for half a second, but says "page fault in nonpaged area".

Actually, while typing this I've had an idea - At the moment I don't have any shared folders configured on this machine, I deleted them after finding it was easier to use regular network shares.

  • Feeling brave, I created a new shared folder, and verified that it worked.
  • I then hovered the mouse over the bad shortcut, saw its name was VBOXSVRDesktop and guessed that I'd shared my Linux desktop.
  • After creating a new shared folder for my desktop, the shortcut works fine, and does not bluescreen windows.

That shortcut has now been deleted and I've again turned off shared folders.

I am 99% sure that this will be reproducible by:

  • Creating a shared folder
  • Creating a shortcut to that shared folder
  • Rebooting (shared folder will disappear since they're transient by default)
  • Attempting to open, move, view properties of, or delete that shortcut - I believe any of these will crash windows.

Change History

comment:1 Changed 5 years ago by frank

I followed your steps but cannot reproduce this problem, guest was WinXPSP3 with 2.2.2 additions installed. The guest just tells me that not all network drives could be restored. Which guest additions do you have installed?

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use