VirtualBox

Ticket #3938 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

Kubuntu 9.04 & Guest additions

Reported by: kestrel1 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I have installed Kubuntu 9.04 as a guest with both a Windows host & a Linux host. The installation goes fine, but when I mount the ISO so that I can install the VBox guest additions I hit a problem. The CD is mounted correctly, but I am unable to see any files on the disc. I get the same result if I use the 'cd' command to get to the /media/cdrom directory & then use the 'ls' command to list the files. I see nothing. If I type 'sudo sh VBoxLinuxAdditions-x86.run' I get a file not found error or something similar. I have used the latest version of VirtualBox (2.2.2) & the slightly older (2.2.0) but get the same result with both. Ubuntu 9.04 & Kubuntu 8.10 both work correctly as virtual machines & I am able to see & install the guest additions in both & have not noticed any problem with other OS's, be them Linux or Microsoft. If this could be looked at I would appreciate it.

Change History

comment:1 Changed 5 years ago by michael

How do you mount the CD, and have you tried mounting it from the command line?

comment:2 Changed 5 years ago by kestrel1

Just done a bit more testing. The way I normally mount the CD rom drive or ISO file is to set it up in the CD Rom options before I start the VM. This normally works OK, but not with Kubuntu 9.04. So I started the VM without the ISO set to auto mount & chose to mount it via the Devices menu option -. Install Guest Additions. On doing this I get a message pop up to inform me what has just been plugged in. If I click on the Guest additions image in this pop up box the CD opens in Dolphin & everything appears as it should & I can see all files. I can then 'cd' to the '/media/cdrom' directory & 'ls' & am able to see the files correctly & install the guest additions. However, I also did the same type of mount after rebooting & instead of clicking on the guest additions image in the pop up box, I went straight to the command line & tried to 'cd' to the directory as I had previously. I get no listing after typing 'ls' I then went to display the CD via Dolphin & I get a blank screen again. The only way to get this working appears to be to click on the guest additions image in the pop up box & letting it open in dolphin first. I tried just opening it straight in Dolphin after mounting the image, but I get no files displayed. This is on the Ubuntu 9.04 Host. I will try it on the Windows host tomorrow, but I suspect I will get the same result. At least I have now managed to install the guest additions, but I can continue testing if you require me to, as it may help others. Thanks

comment:3 Changed 5 years ago by Sasquatch

This bug report is invalid. There is nothing wrong with VB. It's the OS that doesn't trigger the mount command itself when a CD is inserted. The user has to manually mount the CD. When double clicking on the CD icon on the desktop, the mount command is triggered and the files will be visible. Clearly a bug in the Window Manager of the OS or misconfiguration, not VB. For this reason I made the howto ( http://forums.virtualbox.org/viewtopic.php?f=3&t=15679) terminal based and clearly state that the auto-mount isn't always triggered.

comment:4 Changed 5 years ago by kestrel1

OK, point taken & thanks for the link. Case closed.

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use