VirtualBox

Ticket #3876 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Seamless mode does not work across multiple monitors

Reported by: ctrlaltdel85 Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Virtualbox running on a Windows XP host, will not display guest windows in seamless mode on secondary monitors. When the virtualbox guest is in a secondary monitor and seamless mode is switched on, the guest will disappear entirely. When seamless mode is switched on the primary monitor, guest windows cannot be dragged to other displays.

A proposed solution: Render the guest windows inside of native host windows. Treat each guest window like a native application. This is how Xming and Microsoft RemoteApp does seamless rdp. Doing this will solve many other rendering issues (like background windows overlapping the host task bar).

Change History

comment:1 Changed 5 years ago by FineWolf

Reproduced on Vista x32 and x64 Host as well.

comment:2 Changed 5 years ago by Zrax

Reproduced for VBox 3.0 on Vista Host

comment:3 Changed 5 years ago by kassah

Reproduced in Ubuntu 9.04 w/Dual Monitors using Nvidia TwinView.

comment:4 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

This is more or less a duplicate of #2720. See comment 2 on that ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use