VirtualBox

Ticket #3866 (reopened defect)

Opened 5 years ago

Last modified 2 months ago

Host-only interface interferes with the current adapter

Reported by: Frank Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.2.2 Keywords: regression, bug, network
Cc: Guest type: other
Host type: Windows

Description

When the host-only interface is installed, it suddenly screws up the connection for the physical adapter. The adapter says it is identifying the network when it is connected to it already.

Change History

comment:1 Changed 5 years ago by misha

What IP settings does your physical adapter have?
Does your physical adapter connection works ok after the install is complete?
Did you see this happening with the pre-2.2.2 VBox versions?

It is more likely thar this is a Bridged Interface Networking driver (rather than the host-only driver) install that is causing this problem.
When the bridged driver is installed all current network connections get dropped and all adapters re-initiate their settings. This is a known limitation and we display a warning regarding this before the install is started.

comment:2 follow-up: ↓ 3 Changed 5 years ago by Alden

This is critical, I have suffered the same problem, I have installed the new VirtualBox version (2.2.2) and I have lost all connectivity to Internet or my lan due to automatic installation of VirtualBox host only interface, and which is worse, it's not possible to uninstall the VirtualBox or disable this lan adapter, both operations become frozen.

It's a catastrophic failure!!!

comment:3 in reply to: ↑ 2 Changed 5 years ago by misha

Replying to Alden: Am I correct that the connectivity was not restored after the installation complete?
What IP settings does/did your physical adapter have?

comment:4 follow-up: ↓ 5 Changed 5 years ago by Alden

Hi Misha.

After install VirtualBox, reset was requested (take into account I was updating from a VirtualBox 2.1.0). After resetting the computer, the connectivity was lost.

My physical adapter is a Broadcom NetXtreme 57xx Gigabit Controller configured with the typical options for a business network (DHCP server and so on).

I tried to remove this adapter from Network section in VirtualBox preferences, also to disable it from Windows XP, but it's impossible, the operation always becomes frozen.

comment:5 in reply to: ↑ 4 Changed 5 years ago by misha

Replying to Alden: Hmm, that's strange.. The Host-Only adapter gets static ip config 192.168.56.1 mask 255.255.255.0 , so unless your physical adapter network is 192.168.56. you should not experience any problems.
What network does your physical adapter connected to?

Could you also try doing the following: open the properties dialog for your physical adapter network connection and disable (uncheck) the "VirtualBox Bridged Networking Driver" there. Let me know whether this helps.

In case this does not help, try disabling the host-only adapter from the safe mode. It is more likely you will be able to do it from there.

Please let me know whether/what of the above actions help.

host configured to Could you try doing the following:

comment:6 follow-up: ↓ 7 Changed 5 years ago by Alden

Hi Misha.

Finally I have achieved to restore my lan. I tried to uninstall VirtualBox 2.2.2. The operation becomes frozen, so I had to reset my computer, first trying to use the OS and finally pressing the power button as the OS didn't reset due to this problem.

After restarting the system, my lan works again.

About the questions you asked, the Broadcom NetXtreme interface is connected to a common Ethernet 100 lan using the Local Area Connection name under Windows, TCP/IP protocol used, DHCP server enabled.

About your second question, I don't see any VirtualBox Bridged Networking Driver anywhere.

Also I had a XP virtual machine saved from VirtualBox 2.1 and now when I try to restart it the following error message is displayed: "Failed to start the virtual machine Windows XP. VM cannot start because the host interface 'Broadcom NetXtreme 57xx Gigabit Controller does not exist."

comment:7 in reply to: ↑ 6 Changed 5 years ago by misha

Replying to Alden: Is the host-only adapter uninstalled now? Could you tell me the ip settings (address & network mask) your physical adapter gets via DHCP?

Also I had a XP virtual machine saved from VirtualBox 2.1 and now when I try to restart it the following error message is displayed: "Failed to start the virtual machine Windows XP. VM cannot start because the host interface 'Broadcom NetXtreme? 57xx Gigabit Controller does not exist."

Did you re-install any VBox version after the previous uninstall interuption? If not then the problem is in a misconfigured (partially uninstalled) installation you have. Namely the Bridged driver is uninstalled for you now. So you might want to try to uninstall it again and then install from scratch. Alternatively (ONLY if you're running VBox 2.2.2 now) you might try to install the bridged driver manually by clicking "Install" in a property dialog for one of your network connections -> select "service" -> browse to <VBox install dir>\drivers\network\netflt\VBoxNetFlt.inf and click "install". Note again that this is possible only with VBox 2.2.2 version

comment:8 follow-up: ↓ 9 Changed 5 years ago by Alden

Hi Misha.

No, the host-only adapter is currently not uninstalled and also not disabled, the showed state is connected.

About ipconfig:

Subnet Mask: 255.255.255.0 IP obtained from DHCP: 10.xxx.xxx.xxx Default Gateway: 10.xxx.xxx.xxx

No, I haven't reinstalled an old version, but it's sure I will have to do it.

comment:9 in reply to: ↑ 8 Changed 5 years ago by misha

Replying to Alden: so probably your lan connection failure is caused by the bridged networking driver. please let me know whether the downgrade to the older version resolves your problem.
Note that until 2.2.2 you need to uninstall the higher-version VBox before installing the lower-version for the installation to be performed properly.

comment:10 Changed 5 years ago by Alden

Hi Misha.

I have problems. I can't uninstall VirtualBox 2.2.2. As I told you, the uninstallation was not completed, I had to reboot the computer because the uninstallation process became frozen. After it, VirtualBox doesn't appear in the Add or Remove Programs from Windows, but it continues being showed in the Start menu.

As I cannot unistall it, I have tried to install 2.1.4 version, but this error is showed:

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2753."

What can I do now?

comment:11 Changed 5 years ago by misha

Try using the msi cleanup as described in the "Cleaning Up" setion  here

comment:12 Changed 5 years ago by Alden

Hi Misha.

After some reboots and trips, finally I achieved to uninstal the VirtualBox 2.2.2 version completely. However the Virtual Host-Only Network lan continues being showed in Network Connections...

As I achieved to uninstall the 2.2.2, also I have could reinstall the old 2.1.4 version.

But now I have another issue. When I try to open VirtualBox 2.1.4 this message error is showed (by the way, copy text from error window doesn't work!!!):

Cannot convert settings from Version '1.7-windows'

The source version is not supported.

Result Code: VBOX_E_XML_ERROR (0x80BB000A) Component: VirtualBox Interface: IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde} Callee RC: E_NOINTERFACE (0x80004002)

comment:13 follow-ups: ↓ 16 ↓ 18 Changed 5 years ago by Alden

Hi Misha.

I have could solved that issue getting the 1.6 xml version from backup files created by VirtualBox.

But now another problem, when I try to start the virtual machine this error is showed:

Unknown error creating VM (VERR_INTNET_FLT_IF_FAILED).

I'm desperate!!!

comment:14 Changed 5 years ago by Alden

Hi, the problem is the host interface, using NAT the virtual machine runs.

But I need the host interface to have access to the lan of my company!

comment:15 follow-up: ↓ 17 Changed 5 years ago by hommy

The host-only interface can be uninstalled just like any device; go to the device manager

comment:16 in reply to: ↑ 13 Changed 5 years ago by hommy

Replying to Alden:

Hi Misha.

I have could solved that issue getting the 1.6 xml version from backup files created by VirtualBox.

But now another problem, when I try to start the virtual machine this error is showed:

Unknown error creating VM (VERR_INTNET_FLT_IF_FAILED).

I'm desperate!!!

I think VirtualBox 2.2.x is connected to the host interface

comment:17 in reply to: ↑ 15 Changed 5 years ago by hommy

Replying to hommy:

The host-only interface can be uninstalled just like any device; go to the device manager

Read this Alden

comment:18 in reply to: ↑ 13 Changed 5 years ago by misha

Replying to Alden: What Windows and VBox version do you have currently installed?

comment:19 Changed 5 years ago by bazzline

Maybe this can help a little bit.

Today i installed the 2.2.2 version (upgrade from 2.1.4) and i noticed that Microsoft Activesync was not working anymore.

After a reboot my wireless was not working either (i did not try my wired lan connection). Of course i tried also disabling the adapter and the system froze.

At last I did start XP in safe mode, and I disabled all the VirtualBox Host-Only adapters.

And after the reboot everything is working as it should......

comment:20 Changed 5 years ago by Alden

Hi all.

Finally I have achieved to recover the old virtual machine.

The problem was although I uninstalled completely VirtualBox 2.2.2, the Virtual Host-Only adapter continued being installed in the system.

When I installed again VirtualBox 2.1.4, as the Virtual Host-Only adapter continued being installed in the Local Area Connection, the old network bridge interface wasn't installed, so when I started my virtual machine the "Unknown error creating VM (VERR_INTNET_FLT_IF_FAILED)" error message was displayed.

Solution: removed manually the Virtual Host-Only adapter, rebooted and installed again VirtualBox 2.1.4. As now the Virtual Host-Only adapter was not present in the system, the old network bridge interface was installed and now I have could boot my virtual machine.

Anyway, this is a very critical error in VirtualBox and should be solved asap, I see other users have suffered the same problem.

comment:21 follow-up: ↓ 30 Changed 5 years ago by msmcknight

I am also seeing this problem. I am using 2.2.2 on an OpenSolaris 2008.11 host.

The problem does seem to be tied to the Bridged network adapter in that I only seem to get the error when I select it. The error I see is:

Error: failed to start machine. Error message: Failed to open/create the internal network 'HostInterfaceNetworking-e1000g0 - Intel PRO/1000 Gigabit Ethernet' (VERR_INTNET_FLT_IF_FAILED). Failed to attach the network LUN (VERR_INTNET_FLT_IF_FAILED). Unknown error creating VM (VERR_INTNET_FLT_IF_FAILED)

Of interest is that I am trying to run vbox within a Solaris zone. When I do this and select the bridged interface, it fails with the error above and the VM powers off. If I try this from the global zone, it causes the VM to lock up where I cannot stop it and must "kill -9" the underlying processes.

Virtualbox 2.2.2 is the only version I have used on this host, so my case differs from above in that this was not the result of an upgrade.

Any ideas?

comment:22 follow-ups: ↓ 23 ↓ 24 Changed 5 years ago by wwwillem

I installed VB 2.2.4 on Solaris 10 X64. Then I installed a Sol10u7 client. I needed "Host Interface", because this instance is a server. Worked fine in earlier VB versions. But this time I could choose "NAT", "Host-Only Adapter", and a few others, but "Host Interface" wasn't part of the options anymore.

Having chosen "Host-Only Adapter", thinking it was just a new name for "Host Interface", everything has gone hay-wire since then. The host OS didn't have a network connection anymore, even "ifconfig nge0 plumb" fails on me. Reading this thread, I uninstalled the two VB packages, but that didn't resolve anything. Still can't get my networking to work again. What a mess.....

comment:23 in reply to: ↑ 22 Changed 5 years ago by misha

Replying to wwwillem: the "Host Interface" attachment was renamed to "Bridged Interface" since 2.2.0, please use "Bridged" instead

comment:24 in reply to: ↑ 22 Changed 5 years ago by ramshankar

Replying to wwwillem: "Host-Only Adapter" simply just adds a new virtual interface (vboxnet0) on your host. It doesn't go about touching anything else on the system such as your physical interfaces.

comment:25 Changed 5 years ago by wwwillem

Mmmm, let's then say it "shouldn't" :-) touch anything else on the system, because let me assure you, my network interface is "dead as a brick". The nge0 interface can't even be plumbed anymore (message is: interface not found) and the nge1 interface can be plumbed, but can't be configured.

Now this could be a special case, because I first had "Host Interface" enabled on an older VB version (not 100% sure which one exactly), which I uninstalled and then upgraded to VB 2.2.4 with "Host-Only Adapter".

If I find the time, I will try to reproduce this. For now it is 1) using USB sticks to backup my data and 2) reinstall the host OS.

comment:26 Changed 5 years ago by misha

To all seeing this issue on Windows host: We've made fixes to host-only interface for 3.0 for Windows host, could you try VBox 3.0 to see whether the issue is gone?

comment:27 Changed 5 years ago by Alden

Hi Misha.

I confirm in VBox 3.0 this error is solved. In fact it was solved in the previous version, 2.2.4 version.

Thank you very much for all your work.

comment:28 follow-up: ↓ 29 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. If other reporters still see this issue, please reopen this ticket.

comment:29 in reply to: ↑ 28 Changed 5 years ago by beshodrom

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to frank:

Thanks for the feedback. If other reporters still see this issue, please reopen this ticket.

I have similar issue with both VB 3 and VB 3.0.2 on Windows XP sp3 host. After VB 3 install my Intel Wireless 3945ABG was not able to connect (stopping at "registering" step), reboot didn't help. Now I don't remember if after uninstall network was restored but I think no, but I remember that there were a couple of devices left in the device manager that I hardly managed to uninstall with a tip I found after a lot of googling. Some time later I tried with VB 3.0.2 and had the same issue. This time I restored the network without uninstall simply disabling the VirtualBox Bridged Networking Driver on all the adapters. Hope you fix this, cause it's the only reason I didn't switched to VB yet.

comment:30 in reply to: ↑ 21 Changed 5 years ago by bewst

Replying to msmcknight:

I am also seeing this problem. I am using 2.2.2 on an OpenSolaris 2008.11 host.

The problem does seem to be tied to the Bridged network adapter in that I only seem to get the error when I select it. The error I see is:

Error: failed to start machine. Error message: Failed to open/create the internal network 'HostInterfaceNetworking-e1000g0 - Intel PRO/1000 Gigabit Ethernet' (VERR_INTNET_FLT_IF_FAILED). Failed to attach the network LUN (VERR_INTNET_FLT_IF_FAILED). Unknown error creating VM (VERR_INTNET_FLT_IF_FAILED)

Of interest is that I am trying to run vbox within a Solaris zone. When I do this and select the bridged interface, it fails with the error above and the VM powers off. If I try this from the global zone, it causes the VM to lock up where I cannot stop it and must "kill -9" the underlying processes.

Virtualbox 2.2.2 is the only version I have used on this host, so my case differs from above in that this was not the result of an upgrade.

I see *exactly* the same symptoms with VirtualBox 3.0.8 running from within a zone.

comment:31 Changed 4 years ago by misha

To all having this problem on Windows hosts: could you try the latest 3.1 version to see if the problem is fixed with it, and if no, could you specify whether you have any other custom networking-related software installed on your system, e.g. VPN clients, Anti-virus, other hypervisors (like VMWare or Virtual PC), etc.

comment:32 Changed 3 years ago by misha

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing. Please re-open if needed.

comment:33 follow-up: ↓ 34 Changed 3 years ago by bewst

  • Status changed from closed to reopened
  • Resolution fixed deleted

I think it's wrong to close a ticket just because you didn't get a response from a subset of those affected and reporting it. There are still plenty of reports for OpenSolaris hosts.

comment:34 in reply to: ↑ 33 Changed 3 years ago by misha

Replying to bewst: well, the ticket is actually dedicated to host-only adapter issues on windows hosts, but not to bridged interface on solaris (see the summary), so I would suggest to use some solaris+bridged networking ticket or create a new one for the latter problem to make it more visible, but let's keep the current ticket open for now.

To all windows host users: let me know if the problem is still relevant for you.

comment:35 Changed 6 months ago by jdn2592ndtw

It's still a problem - Using Windows 7 Pro 64-bit, installing a broadcom network LAN adapter as the sole connection, verifying that it works, and then installing Virtualbox 4.3.2 results in the "Local Area Connection" to be replaced by "Virtualbox Host-Only Network", breaking the normal connectivity of the operating system. This can be fixed by uninstalling and re-installing the broadcom network lan adapter, after which both "Local Area Connection" and "Virtualbox Host-Only Network" are displayed.

comment:36 Changed 2 months ago by al881

This is still an issue and is consistent.

The host OS is Windows 7 Pro. The guest Os is Oracle Linux After about 15 minutes the internet connection is lost (all machines on the network). I had to power down my modem to get any access.

After getting a connection back, I ran another Os (Mint) and this works fine. I have 6 virtuals. Os's like Suse and Mint work fine. For some reason the Oracle Linux is the issue.

No changes to my guest network. I took defaults (uses DHCP) but knocks my entire network out.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use