VirtualBox

Ticket #386 (closed defect: duplicate)

Opened 7 years ago

Last modified 4 years ago

Debian guest freezes on booting from ISO

Reported by: dodger48 Owned by:
Priority: critical Component: other
Version: VirtualBox 1.4.0 Keywords: freeze booting iso
Cc: Guest type: other
Host type: other

Description

Hi,

I'm creating installation ISO images for my Debian based software distribution system. The ISO file is used directly to boot VirtualBox from. The included installation script or the Linux kernel are freezing anomalous at different stages of the booting or script execution.

Sometimes the freeze is when the Linux kernel loads the module for the VirtualBox harddisk controler. On all accounts the freeze occurrs when the virtual disk should be formated. VirtualBox 1.3.8 did not have this freeze. I get it in the OSE SVN version and the current 1.4.0.

I'm attaching the last log file.

Attachments

VBox.log Download (34.1 KB) - added by dodger48 7 years ago.
m23vbox-2007-06-08-14-14-08.log Download (172.8 KB) - added by dodger48 7 years ago.
VBox.2.log Download (138.2 KB) - added by dodger48 7 years ago.

Change History

Changed 7 years ago by dodger48

comment:2 Changed 7 years ago by dodger48

I don't know what it was but the freezing disappeared after using an old kernel configuration and making oldconfigure. After a recompilation of the kernel the ISO can be booted, the partitioning and formating works. Also the extraction of tha base system. At a later installation step VirtualBox freezes again. Maybe the attached log may help.

Changed 7 years ago by dodger48

comment:3 Changed 7 years ago by sandervl73

Still the same with the latest svn?

comment:4 Changed 7 years ago by dodger48

I've just downloaded and compiled rev 3344 from the SVN. Nothing changed. VBox freezes at formating the disk. I'm attaching the new log file.

Changed 7 years ago by dodger48

comment:5 Changed 7 years ago by sandervl73

I guess you're the same guy I talked to on irc. Anyway, I've reproduced the problem, but it's not a trivial one. Some kind of corruption.

comment:6 Changed 7 years ago by dodger48

Yes, I am. Did you made an advancement in finding a solution? Is there anything I can do to speed up the progress?

comment:7 Changed 7 years ago by sandervl73

No, I haven't had time to look into it further. Nothing more needed from your side as I can reproduce it. Well, only one thing: patience. :) We'll try to have this fixed before the next release.

comment:8 Changed 7 years ago by sandervl73

  • Priority changed from major to critical

comment:9 Changed 7 years ago by sandervl73

By the way, I couldn't reproduce it with hardware virtualization turned on. If your system has a cpu with such capability, then you might want to turn in on.

comment:10 Changed 7 years ago by sandervl73

  • Summary changed from VirtualBox freezes on booting from ISO to Debian guest freezes on booting from ISO

comment:11 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of 497. (it's a more generic problem)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use