VirtualBox

Ticket #3831 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

PUEL 2.2 x64 on OpenSuse 11.1 x64 FATAL: Error inserting vboxdrv (/lib/mo.../vboxdrv.ko): Invalid module format

Reported by: rosieres Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords: vboxdrv.ko installation error
Cc: Guest type: other
Host type: Linux

Description

if i try to install VirtualBox-2.2.0-45846-Linux_amd64.run on OpenSuSE 11.1 x64 the vboxdrv.ko seems to be invalid. i deinstalled all virtualbox components. checked if any vbox rpms are installed, removed any config files. removed any existing vboxdrv.ko files. rebooted the machine and tried the installation again. everytime the same error even if i do an /etc/init.d/vboxdrv setup

uname -a Linux linquad 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa kernel* linux* kernel-default-base-2.6.27.21-0.1.2 kernel-default-2.6.27.21-0.1.2 kernel-source-2.6.27.21-0.1.1 linux32-1.0-475.8 kernel-default-extra-2.6.27.21-0.1.2 linux-atm-lib-2.5.0-135.14 linux-kernel-headers-2.6.27-2.28 kernel-syms-2.6.27.21-0.1.1

modprobe vboxdrv FATAL: Error inserting vboxdrv (/lib/modules/2.6.27.21-0.1-default/updates/vboxdrv.ko): Invalid module format

dmesg vboxdrv: no symbol version for struct_module vboxdrv: no symbol version for struct_module

less /var/log/vbox-install.log VirtualBox 2.2.0 installer, built 2009-04-07T19:29:31Z.

Testing system setup... System setup appears correct.

Installing VirtualBox to /opt/VirtualBox

Output from the module build process (the Linux kernel build system) follows:

Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxdrv/2.2.0/source ->

/usr/src/vboxdrv-2.2.0

DKMS: add Completed.

Preparing kernel 2.6.27.21-0.1-default for module build: (This is not compiling a kernel, just preparing kernel symbols) Storing current .config to be restored when complete using presented .config make oldconfig........ make prepare.......

Building module: cleaning build area.... make KERNELRELEASE=2.6.27.21-0.1-default -C /lib/modules/2.6.27.21-0.1-default/build M=/var/lib/dkms/vboxdrv/2.2.0/build.......

Running the post_build script: cleaning build area.... cleaning kernel tree (make mrproper).......

DKMS: build Completed. Running module version sanity check.

vboxdrv.ko:

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/2.6.27.21-0.1-default/updates/

Adding any weak-modules

depmod......

DKMS: install Completed. Output from the module build process (the Linux kernel build system) follows: Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxnetflt/2.2.0/source ->

/usr/src/vboxnetflt-2.2.0

DKMS: add Completed.

Preparing kernel 2.6.27.21-0.1-default for module build: (This is not compiling a kernel, just preparing kernel symbols) Storing current .config to be restored when complete using presented .config make oldconfig.... make prepare.....

Running the pre_build script:

Building module: cleaning build area.... make KERNELRELEASE=2.6.27.21-0.1-default -C /lib/modules/2.6.27.21-0.1-default/build M=/var/lib/dkms/vboxnetflt/2.2.0/build...... cleaning build area.... cleaning kernel tree (make mrproper)....

DKMS: build Completed. Running module version sanity check.

vboxnetflt.ko:

  • Original module
    • No original module exists within this kernel
  • Installation
    • Installing to /lib/modules/2.6.27.21-0.1-default/updates/

Adding any weak-modules

depmod....

DKMS: install Completed. Starting VirtualBox kernel module..failed

(modprobe vboxdrv failed. Please use 'dmesg' to find out why)

End of the output from the Linux kernel build system. Installation successful

Change History

comment:1 Changed 5 years ago by frank

Where do you have that DKMS package from? AFAIK, openSUSE does not come with DKMS? I just installed VBox 2.2.0 successfully on an up-to-date openSUSE 11.1 x86_64.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I will close this bug as duplicate of #3651. Please answer there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use