VirtualBox

Ticket #3794 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

XP 64bit host crash when pasting from vrdp, guest->host not working

Reported by: DesktopMan Owned by:
Priority: major Component: clipboard
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Vbox: 2.2.0 r45846

Host: XP 64bit

Guest: Ubuntu 9.04 RC1 64bit, additions installed

Cmd: VBoxHeadless.exe -s "Ubuntu 9.04 RC1"

Description: Clipboard sharing over vrdp does not function properly. I can copy from host to guest, but not guest to host. I can also reproduce an explorer.exe crash while pasting from guest to host. Both bugs happen running headless and running from gui with vrdp enabled. Posted both bugs together as they might be related.

Attachments

VBox.log Download (41.4 KB) - added by DesktopMan 5 years ago.

Change History

Changed 5 years ago by DesktopMan

comment:1 Changed 5 years ago by frank

Please check the latest release VirtualBox 2.2.2.

comment:2 Changed 5 years ago by DesktopMan

VirtualBox 2.2.2 make no difference. Host crash still present.

comment:3 Changed 5 years ago by frank

Thanks for testing this. Are you sure that the host crashed during such a copy operation? Is that host crash reproducible?

And did you upgrade the guest additions to version 2.2.2? Sorry for asking, have to make sure we don't miss anything.

comment:4 Changed 5 years ago by DesktopMan

Guest additions are at 2.2.2. Is that relevant? It's not required to enable vrdp.

New information though: It crashes the host application I paste to, which, when I was testing, was the Run box of windows. Thus the explorer crash. If I paste to notepad, notepad crashes.

The trigger seems to be the current order:

  1. copy in vrdp past to host, nothing is pasted but doesn't crash
  2. copy host, paste in vrdp, past works as intended.
  3. copy in vrdp paste to host, host application hangs.
  4. if I close vrdp at this point, the host application works again.

With this order it happens 100% of the time. If only do point 1 over and over there is no crash, but nothing pasted either.

comment:5 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.2.0 to VirtualBox 2.2.2

comment:6 Changed 5 years ago by DesktopMan

Update: Still happens in 3.0.2

comment:7 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use