VirtualBox

Ticket #3782 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Unable to sort by column with Mouse Integration Enabled. -> fixed in SVN

Reported by: bassmadrigal Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Linux
Host type: other

Description

Host: Windows XP Pro Guest: Slackware 12.2 updated to -current VirtualBox: 2.2.0

Install Slackware 12.2 from the dvd and do all the upgrades to current which will have you running KDE 4.2.2 with qt-copy r948357 (KDE's version of QT with changes not yet made upstream). It has also been tried with various versions of the vanilla qt version.

The issue is whenever mouse integration is enabled, you are unable to sort by columns. When you click on it it highlights the entire area. This seems to happen in every qt4 based program. Click on Machine -> Disable Mouse Integration and you can then click on the columns and sort by whichever column you choose. Re-enable mouse integration and you are unable to sort anymore.

Attachments

vbox.log Download (38.9 KB) - added by bassmadrigal 5 years ago.
bug-3782-slack.ovf Download (4.6 KB) - added by bassmadrigal 5 years ago.
ovf file for incoming bug-3782-slack.vmdk
bug-3782-slack.xml Download (3.6 KB) - added by bassmadrigal 5 years ago.
xml file for incoming bug-3782-slack.vmdk

Change History

Changed 5 years ago by bassmadrigal

comment:1 Changed 5 years ago by michael

Would you be able to make a hard disk image which shows this behaviour available? Or to find a way to reproduce it with a guest which requires less time to set up than slackware-current?

comment:2 Changed 5 years ago by bassmadrigal

Where is a good place to upload it to?? I just set up a new machine and did an export of the appliance and the vmdk is about 3.5GB.

comment:3 Changed 5 years ago by frank

Please could you contact me by private E-mail at frank _dot_ mehnert _at_ sun _dot_ com?

comment:4 Changed 5 years ago by bassmadrigal

I sent off the email (my email is my username here and I am with yahoo).

I also upgraded to 2.2.2 tonight along with upgrading Guest Additions, and the problem still exists in both my main machine and the machine I setup for this bug report.

comment:5 Changed 5 years ago by frank

bassmadrigal, did you really sent me an E-mail? I can't find one from you in my incoming folder. Please could you try again? Please mention '3782' in the subject. Thank you!

comment:6 Changed 5 years ago by bassmadrigal

I don't know what happened, but I sent it out again.

Changed 5 years ago by bassmadrigal

ovf file for incoming bug-3782-slack.vmdk

Changed 5 years ago by bassmadrigal

xml file for incoming bug-3782-slack.vmdk

comment:7 Changed 5 years ago by bassmadrigal

Started the uploading process now, but I have a slow connection, so it will take about 12 hours. So it should finish by 1200 GMT on the 6th of May.

As a side note, the virtual machine crashes on logging out of KDE, but it is un-related to the bug.

If wanted I can put the login information directly in here.

comment:8 Changed 5 years ago by bassmadrigal

File completed uploading. It is named bug-3782-slack.vmdk

Again, let me know if you want the login information here or in an email.

comment:9 Changed 5 years ago by michael

Thanks for the image. Currently downloading, five hours left to go :)

comment:10 Changed 5 years ago by bassmadrigal

I guess I can go ahead and post the login info here.

root passwd 12345 user account is

test passwd 12345

comment:11 Changed 5 years ago by michael

Not sure if I understood right how to reproduce this. In Dolphin, when I set detailed view, I was able to sort by any column I wanted to. VirtualBox from SVN, Additions not changed from the ones you installed. Could you provide more information? Thanks.

comment:12 Changed 5 years ago by bassmadrigal

That is weird. I never tried dolphin. It works on mine too.

But if you load up akregator (it does the same thing with ktorrent, which is why I figured it was all the qt apps) and try and sort there, it will not work unless you disable mouse integration.

comment:13 Changed 5 years ago by michael

It looks to me like the problem is that, for implementation-related reasons, VBox always sends minute mouse movements when a mouse event occurs and mouse integration is active. So when we click in Akgregator it always sees a small mouse movement (one pixel right, one down) in-between the button down and button up events, and I assume that doesn't like this. Unfortunately, just fiddling VBox enough to test this hypothesis will be a bit of work.

comment:14 Changed 5 years ago by michael

And when you said that the virtual machine crashes when you log out, I didn't realise that you meant a full hang of the host (at least that is what I get)!

comment:15 Changed 5 years ago by bassmadrigal

My host doesn't hang, just the VM. It might be an issue with something with Slackware since it is running current. My normal machine that I have running doesn't do that.

So as far as the mouse integration, is this a VBox bug, or a QT bug or a bug related to something else? Because I have no problems submitting bug reports for others, if it isn't related to an issue with VBox.

And thanks for the time and effort you take for VBox. I love this program.

comment:16 Changed 5 years ago by michael

To the first, we will have to look at the hang anyway, because the guest should not be able to hang the host, no matter what it does. To the second, in a way it is a bug in both - VBox should not really do that, but Akgregator should be more tolerant, because the same event sequence could happen in real life, say if the user had shaky hands.

comment:17 Changed 5 years ago by michael

  • Summary changed from Unable to sort by column with Mouse Integration Enabled. to Unable to sort by column with Mouse Integration Enabled. -> fixed in SVN

We have changed the pointer integration code slightly to work around this.

comment:18 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use