VirtualBox

Ticket #3773 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Pass all mouse events to the guest -> fixed in SVN

Reported by: alexk Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Change History

comment:1 Changed 5 years ago by frank

The problem is that the emulated mouse does only provide a limited number of mouse buttons -- the hardware specification simply doesn't define more than three buttons.

However, using the guest additions it should be possible to pass more button events to the guest.

comment:2 Changed 4 years ago by michael

  • Summary changed from Pass all mouse events to the guest to Pass all mouse events to the guest -> fixed in SVN

We now pass five buttons to the guest. We also pass the vertical "tilt" scroll wheel, but only Linux guests seem to recognise this. For the record, a physical XP installation also refused to recognise the tilt wheel of a Microsoft mouse connected to the PS/2 port.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 4 years ago by bqbauer

This does not appear to work in OpenSolaris guests of an OpenSolaris host. The guest web browser doesn't respond to the mouse buttons like the host. OpenSolaris web browsers normally respond to these buttons as in any other OS. Tested with FireFox 3.5.5 from opensolaris.org and with the stock 3.1 beta that comes with 2009.06.

An XP guest of the same host does recognize these new buttons.

comment:5 Changed 4 years ago by michael

It may be that OpenSolaris recognises the extra buttons on a USB mouse but not on a PS/2 one, which is what we emulate. The code seems to be there (in OpenSolaris) as far as I can see though from a quick search in the sources. Perhaps explicitly specifying a number of buttons in xorg.conf in the guest will make a difference? Bear in mind that at least buttons 4 and 5 are the vertical scroll wheel, and possibly (?) 6 and 7 the horizontal one.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use