VirtualBox

Ticket #3757 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

tftp failure in VirtualBox

Reported by: kohsuke Owned by:
Priority: major Component: network
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by Hachiman) (diff)

There appears to be a bug in the TFTP implementation of the PXE boot of VirtualBox. The packet capture from Wireshark is attached.

As you can see in the packet capture, TFTP transmission of a file starts off fine, but somehow VirtualBox fails to recognize the data packet 67 that the TFTP server is sending.

It keeps ACKing 66 to request a re-transmission of 67, which the TFTP server does. Eventually, both parties time out and the TFTP fails.

The error reproduces often, but not always. It's not always this packet 67, either. It more or less happens at random points, but the probability of the issue is high enough that if I attempt a Linux kernel boot via pxelinux, it'll almost always fail before the linux kernel image and initrd is loaded.

Thank you for reporting. Could you please attach your log file to the ticket?

Attachments

tftp-virtualbox Download (298.2 KB) - added by kohsuke 5 years ago.
Wireshark packet capture that shows communication between TFTP server and VirtualBox
VBox_Logs_WinXP_RIS.zip Download (37.5 KB) - added by MrX1980 5 years ago.
Logs of the RIS
VBox_Logs_Win2003.zip Download (38.3 KB) - added by MrX1980 5 years ago.
Logs of the Win2003

Change History

Changed 5 years ago by kohsuke

Wireshark packet capture that shows communication between TFTP server and VirtualBox

comment:1 Changed 5 years ago by kohsuke

In this case, the TFTP server is the host of VirtualBox, and VirtualBox is connected to network via a host interface.

comment:2 Changed 5 years ago by michaln

  • Component changed from other to network

This is a packet capture taken on the host NIC, yes? Could you please try this again and capture both the traffic on the NIC (with Wireshark or similar) *and* at the same time create a VM trace using VBoxManage modifyvm with the -nictrace and -nictracefile options? That way we'll be able to tell if the problem is in the PXE ROM code or if packets are getting lost on the way.

I'm also wondering why Wireshark tells me almost all the packets sent by your host have incorrect checksum?

Finally, what exactly is your host OS and the TFTP server? The VirtualBox PXE implementation is known to work with a number of hosts and TFTP servers, so the precise versions you're using may be important.

comment:3 Changed 5 years ago by MrX1980

Hello

I have the same or similar problem.

VirtualBox 3.0.0 beta 2
Host: Win XP Pro SP3 german
Guest: Win 2003 Enterprise SP2 german
RIS: Should be Win XP Pro SP3 german

Internel Network

Messages in Win2003:

Fehler beim Erstellen des UDP-Endpunkts für den WDSPXE-Anbieter auf der Schnittstelle "192.168.39.133:67". Dieser Fehler kann auftreten, wenn die Netzwerkschnittstelle deaktiviert bzw. geändert wurde oder wenn eine andere Anwendung diesen Port bereits verwendet. Der Anbieter kann über diese Schnittstelle keine Anforderungen empfangen. Fehlerinformationen: 0x2740

Fehler beim Erstellen des UDP-Endpunkts für den WDSPXE-Anbieter auf der Schnittstelle "192.168.39.133:68". Dieser Fehler kann auftreten, wenn die Netzwerkschnittstelle deaktiviert bzw. geändert wurde oder wenn eine andere Anwendung diesen Port bereits verwendet. Der Anbieter kann über diese Schnittstelle keine Anforderungen empfangen. Fehlerinformationen: 0x2740

The logs will follow.

Changed 5 years ago by MrX1980

Logs of the RIS

Changed 5 years ago by MrX1980

Logs of the Win2003

comment:4 follow-up: ↓ 5 Changed 5 years ago by kohsuke

Incorrect checksums seem to be the standard affair of IP packets. Every time I capture traffic anywhere, I always see the incorrect checksums. So I doubt if it's related.

I'll try the vmtrace when I get a chance.

comment:5 in reply to: ↑ 4 Changed 5 years ago by Hachiman

  • Description modified (diff)

Replying to kohsuke:

Incorrect checksums seem to be the standard affair of IP packets. Every time I capture traffic anywhere, I always see the incorrect checksums. So I doubt if it's related.

I'll try the vmtrace when I get a chance.

comment:6 follow-up: ↓ 7 Changed 5 years ago by MrX1980

With VirtualBox 3.0 Final still the same.

comment:7 in reply to: ↑ 6 Changed 4 years ago by klaus

Replying to MrX1980:

With VirtualBox 3.0 Final still the same.

Are you 100% sure that you get the same problem? Did you verify with a sniffer that TFTP keeps retransmitting packet 67 over and over again?

You've provided logs (unlike all the others), so I can tell that your observation is with the Intel PXE code. Don't know about the original reporter.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing. Before you consider to reopen the ticket, check if the problem persists with VBox 4.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use