VirtualBox

Ticket #3692 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

nameserver problems with DHCP on gentoo -> Fixed in svn

Reported by: tyoma53 Owned by:
Priority: minor Component: network/NAT
Version: VirtualBox 2.2.0 Keywords: gentoo dhcp dns
Cc: Guest type: Linux
Host type: Windows

Description

With new VirtualBox 2.2.0 there is problem with nameservers on Gentoo guest and Windows XP host.

For my guest Gentoo system I can't become right nameserver via DHCP. I'm using NAT for network service.

So when I'm trying to become DNS servers IP addresses via DHCP in /etc/resolv.conf I see this: nameserver 104.10.146.9 nameserver 0.0.0.0

For example, on CentOS guest on the same host machine everything works fine with DHCP: nameserver 192.168.0.1 nameserver 79.171.*.*

Attachments

Gentoo-2009-04-10-12-46-08.log Download (42.5 KB) - added by tyoma53 5 years ago.
Gentoo-2009-04-29-11-04-56.log Download (41.0 KB) - added by tyoma53 5 years ago.

Change History

comment:1 Changed 5 years ago by Hachiman

thank you for reporting. Could you please attach the Log file

As workaround you can try to enable DNSProxy

#VBoxManage setextradata "Linux Guest" "VBoxInternal/Devices/pcnet/0/LUN#0/Config/DNSProxy" 1   

I'll invetigate an issue.

Changed 5 years ago by tyoma53

comment:2 Changed 5 years ago by tyoma53

thanks for help.

which parameters i must replace in this command with my own settings (of course i replace "Linux Guest" with my VM name)?

i ran this command, but now when i'm trying to boot this VM i become this error (this is cyrillic):

Код ошибки: (Error Code)
E_FAIL (0x80004005)
Компонент: (Component)
Console
Интерфейс: (Interface)
IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

i forgot to write: i'm using 2 Intel PRO/1000 MT Desktop as nics and configured them in bonding.

comment:3 Changed 5 years ago by tyoma53

wow, i can't edit my own message?

i tried to use DHCP with standalone interfaces (eth0, eth1), but couldn't become DNS IPs too.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #3655.

comment:5 Changed 5 years ago by tyoma53

how it can be duplicate? dhcp behind NAT works well by me with all my guest Linux/BSD hosts. and in Gentoo it works also well, only the problem with nameservers.

i think those problems absolutelly different.

comment:6 Changed 5 years ago by frank

I'm still quite sure that this is a duplicate as the problem actually is nameserver-related. I hope we can post an updated Windows binary within the next days (still takes some time), then you could check if the update solves your problem.

comment:7 Changed 5 years ago by tyoma53

i've tried 2.2.2 release, but this problem is still exist.

i repeat once again: dhcp is works on all my guest hosts via NAT and they recive right DNS servers addresses, but gentoo guest host just receive IP-address and can't receive right DNS servers IP's.

comment:8 Changed 5 years ago by frank

tyoma53, to make sure: your Gentoo guest does not receive any DNS server IPs? Please attach a VBox.log file of your Gentoo VM session.

Changed 5 years ago by tyoma53

comment:9 Changed 5 years ago by tyoma53

so i add a new log file.

i don't know what DHCP-client becomes about DNS, but resolv.conf looks so:

search nameserver 120.91.18.8 nameserver 0.0.0.0

my DNS servers have absolute different ip's.

comment:10 Changed 5 years ago by dflogeras

I can confirm this one as well. The problem for me began in 2.2.0. Among 4 different guests, the Gentoo guest is the only one exhibiting this behaviour. It correctly gets an IP from the DHCP server (that is within the correct IP range), but the DNS being pushed to it is incorrect. Seemingly the first DNS address is just a random IP (after restarting networking it changes), and the second is always 0.0.0.0.

This problem persists with 2.2.2 release. I suggest re-opening the bug

comment:11 follow-up: ↓ 13 Changed 5 years ago by dflogeras

For what it's worth, I'm running dhcpcd 4.0.7

comment:12 Changed 5 years ago by dflogeras

Also, my host machine is Gentoo as well, not Windows like tyoma53.

comment:13 in reply to: ↑ 11 ; follow-up: ↓ 15 Changed 5 years ago by Hachiman

Replying to dflogeras:

For what it's worth, I'm running dhcpcd 4.0.7

Could you please give me some information about Gentoo your distribution source? I can't reproduce it by loading Gentoo from "install-x86-minimal-2008.0.iso" downloaded from Gentoo. Here dhcpcd doesn't print any version or I just don't know how to enforce it to do it. Would you mind send me your hosts resolv.conf at [vasily [dot] levchenko [at] Sun [dot] COM]. And as the last please attach your log file to the defect.

comment:14 Changed 5 years ago by frank

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:15 in reply to: ↑ 13 Changed 5 years ago by nvinson

Replying to Hachiman:

Replying to dflogeras:

For what it's worth, I'm running dhcpcd 4.0.7

Could you please give me some information about Gentoo your distribution source? I can't reproduce it by loading Gentoo from "install-x86-minimal-2008.0.iso" downloaded from Gentoo. Here dhcpcd doesn't print any version or I just don't know how to enforce it to do it. Would you mind send me your hosts resolv.conf at [vasily [dot] levchenko [at] Sun [dot] COM]. And as the last please attach your log file to the defect.

Hachiman: the install disks are somewhat dated (even the 2008.0 one), so it's very likely that the install disk is using an older version of dhcpcd. In fact, the "install-amd64-minimal-2008.0.iso" uses dhcpcd-3.1.5.

I've seen the same issue using dhcpcd-4.0.7 and dhcpcd-4.0.8; reverting to dhcpcd-3.2.3 seems to be an appropriate workaround for this problem.

To get the version number from dhcpcd run the command: dhcpcd --version

comment:16 Changed 5 years ago by tyoma53

yap, i've downgraded dhcpcd to version 3.2.3 and everything now works fine. so i think we can't close this ticket, 'cause it's gentoo dhcpcd-4.0.x problem.

a lot of thanks to everybody who helps me and sorry for stealing your time.

comment:17 Changed 5 years ago by frank

I would like to keep this ticket open for some time. The question is if this Gentoo DHCP client has a bug or if it does something different which is legal but not (yet) supported by the VBox built-in DHCP server. Does it work reliably on real hardware?

comment:18 Changed 5 years ago by tyoma53

i don't know. we use static ips on real hardware. i'll try to test it somewhere.

comment:19 Changed 5 years ago by dflogeras

I have several gentoo machines running DHCP on a wide variety of DHCP servers (from IPCop firewall, and various router devices). My main laptop has been used in hotels/airports all over, and has never exhibited an issue. That's not to say it still might not be a dhcpcd bug, but I can vouch that it works well normally.

This is the implementation that Gentoo uses by default, if you need to contact its author.  http://roy.marples.name/projects/dhcpcd

comment:20 Changed 5 years ago by tyoma53

so we can surelly say that this bug occurs only on VB gentoo guests hosts? if it so, i can send link to this ticket to dhcpcd developer.

comment:21 Changed 5 years ago by MarcoMolteni

I can confirm the same problem with gentoo as guest and the standard dhcpcd 4.x that comes with gentoo. As I workaround I deinstalled dhcpcd (emerge --unmerge dhcpcd) and installed dhcp (emerge dhcp). Now resolv.conf gets populated correctly.

comment:22 Changed 5 years ago by Hachiman

  • Summary changed from nameserver problems with DHCP on gentoo to nameserver problems with DHCP on gentoo -> Fixed in svn

comment:23 follow-up: ↓ 24 Changed 5 years ago by dflogeras

Thanks!

Will it be making the next release? Do you have an approximate timeframe?

comment:24 in reply to: ↑ 23 Changed 5 years ago by Hachiman

Replying to dflogeras:

Thanks!

Will it be making the next release? Do you have an approximate timeframe?

Yes, it will be in next release. It will be released in month or about, can't give more sharp date at the moment.

comment:25 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:26 Changed 5 years ago by dflogeras

Works for me after updating to 2.2.4 (binary version, r47978)

Thanks again!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use