VirtualBox

Ticket #3671 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

After installing VirtualBox 2.2.0 IBM DB2 Warehouse Center product stops working - it gets error timeout

Reported by: abcuser Owned by:
Priority: critical Component: network
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Hi, I have installed VirtualBox 2.2.0 on Windows XP SP3 and after installation I tried to use "IBM DB2 Warehouse Center" client product on host that connects to Warehouse server on another Windows machine.

After 1 minute I get error from warehouse product: "DWC09117E VWERR_Q_TIMEOUT Message queue timeout occurred before message received. RC = 9117 RC2 = 0". This error means warehouse client tries to connect to warehouse server but is not able to get connection working, so it gets timeout error. I am sure this is not warehouse server problem, because I can connect to that product from other machine.

Detailed info from warehouse: "DWC09117E VWERR_Q_TIMEOUT Message queue timeout occurred before

message received.

Explanation:

A Data Warehouse Center internal error occurred.

User Response:

  1. If importing table names, restrict the list to fewer tables.

Some ways to do this are:

  • Request tables but not views.
  • Use a table qualifier.
  • Request a table qualifier and table name.
  1. Increase the agent start/stop timeout in the configuration.
  1. If this is not successful, record all details of this error

message and contact IBM Software Support with the information."

I am 100% sure this bug is related to VirtualBox 2.2.0. Why? Because I have had installed VirtualBox 2.1.4 and warehouse client worked OK. I have created backup of whole windows primary partition. I installed VirtualBox 2.2.0 beta2 and got this error. I restored Windows host partition back to 2.1.4 and warehouse client was working fine. Now I have installed 2.2.0 final and got the same error. Now I have to revent back to 2.1.4.

It looks like 2.2.0 corrupts some network settings or something like that.

I have attached Vbox.log file at another issue I have:  http://www.virtualbox.org/ticket/3668

By the way, I have also reported bug:  http://www.virtualbox.org/ticket/3670 which is network related, but I am not sure this is the same bug. Regards

Change History

comment:1 Changed 5 years ago by abcuser

Hi, I restore Windows partition and now in VirtualBox 2.1.4 this problem does not appear. By the way I am using VirtualBox from version 1.3.8 and never had this kind of problem related to Warehouse Center. Last working version was VirtualBox 2.1.4. I have first noticed this problem using 2.2.0 beta2 and now in 2.2.0.

This is really nasty bug, because it prevents me to have VirtualBox 2.2.0 in the first place. Regards

comment:2 Changed 5 years ago by misha

Do you have other networking (like web browsing, etc.) working on your host with VBox 2.2 installed?

It would be great if you could try install VBox 2.2 and

  1. in device manager disable the "VirtualBox Host-Only Ethernet Adapter" and see if it fixes the problem
  2. if (1) does not help open properties for the network connection you're using for internet access -> there should be a "VirtualBox Bridged Networking Driver" service entry there. Uncheck (disable) this entry, press OK, and see if this fixes the problem.

comment:3 Changed 5 years ago by abcuser

Hi, I have installed 2.2.0 again. I have disabled "VirtualBox Host-Only Ethernet Adapter" in device manager (your suggestion number 1) and now problem with warehouse product disapeared - it is working fine.

I have made some more tests. If I disable device (1) and start warehouse product, then enable device warehouse product is working fine without any problem althrough VirtulaBox Host-Only Ethernet Adapter is enabled. But if I close warehouse product and try to reconnect to warehouser server, it gets connection timeout again. Disabling device (1) again and warehouse product can connect again. It looks there is somekind of trouble in establishing service.

On my computer is also installed "WMware Player 2.5.1 build-126130" that also has some network devices, I also tried to disable them and start virtualbox device and it is not working. It looks like there is no problem of being installed WMware Player and VirtualBox on the same computer, it looks there is some kind of bug in VirtualBox Host-Only Ethernet Adapter.

Please see picture of my network adapters in device manager.  http://www.shrani.si/f/1z/XE/4fmwUqU2/vbox.png

Hope this helps. Regards

comment:4 follow-up: ↓ 6 Changed 5 years ago by abcuser

Hi,
I have also tried to disable all other network devices and only let "VirtualBox Host-Only Ethernet Adapter" (1) and "Intel PRO/1000 PL Network Connection" (my LAN device) enabled and warehouse product is still not working. It really looks like there is some bug in device (1). Hope this helps
Regards

comment:5 Changed 5 years ago by abcuser

Hi,
one more info. If I disable "VirtualBox Host-Only Ethernet Adapter" every program I use works fine. It also works fine any VirtualBox guest access to internet. Regards

comment:6 in reply to: ↑ 4 ; follow-up: ↓ 11 Changed 5 years ago by misha

Thanks very much for the info. Is this only Warehouse Center that experiences problems with the host-only interface enabled?
Does other networking (like web browsing, etc.) works OK with the host-only interface enabled?

comment:7 Changed 5 years ago by abcuser

Hi, on Windows host I have multiple products that access network connection:

  • DB2 database client (can access database server on other machine)
  • Hyperion business intelligence client (can access hyperion server on other machine)
  • Firefox 3.0 browser (can access internet application),
  • Thunderbird 2.0 e-mail client (can access e-mail server)
  • etc.

Any other program can access network, only warehouse client can't.

Don't know if this is some kind of port conflict. I know warehouser server is using following tpc ports: 11000, 11001, 11002.

During warehouse connecting to server (and Vbox device enabled) I executed command:
netstat -ano | find "WAIT"
to see what is happening, and got back:

TCP 127.0.0.1:30606 127.0.0.1:3164 TIME_WAIT 0
TCP 192.168.5.36:3161 192.168.55.108:11000 TIME_WAIT 0

192.68.5.36 is my computer, 192.168.55.108 is warehouse server computer, don't know what is 30606 and 3164 ports. Does this helps?

Do you need any other info? Regards

comment:8 Changed 5 years ago by abcuser

If I disable Vbox device and after warehouse connect to warehouse server, netstat -ano returns:
TCP 192.168.5.36:3219 192.168.55.108:50000 ESTABLISHED 3620

comment:9 Changed 5 years ago by misha

It would be also very useful to know what "route print" & "ipconfig /all" say.
Could you execute those in the command line and post me their output.
You could send the result to me via e-mail at Mikhail dot Sennikovsky at sun dot com if you wish.

comment:10 Changed 5 years ago by abcuser

Mikhail, I sent you an e-mail with two commands requested.

comment:11 in reply to: ↑ 6 Changed 5 years ago by hardon

Replying to misha:

Does other networking (like web browsing, etc.) works OK with the host-only interface enabled?

No, nothing works if host-only interface is enabled.

comment:12 Changed 5 years ago by abcuser

hardon, that is not the case in my sample. If host-only interface is enabled all products (also web browser) can access internet without any problem at all, exception is only warehouse client that gets connection timeout error.

comment:13 Changed 5 years ago by misha

The issue should be solved now.
For those willing to try a fix: please send me a mail at Mikhail dot Sennikovsky at sun dot com. I'll then send you a link to a new test VBox version containing the fix.

comment:14 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in 2.2.2.

comment:15 Changed 5 years ago by abcuser

I have tested 2.2.2 version and I can confirm that problems is solved. Thanks a lot for helping me out.

comment:16 Changed 5 years ago by sandervl73

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use