VirtualBox

Ticket #3658 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Host Interface networking hangs VB

Reported by: CaptainFlint Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.2.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Host OS: Vista Business 32-bit Guest OS: openSUSE 11.1 32-bit

If I set Host Interface networking for the VM and start using this connection intensively, first guest OS hangs completely, and when I try to do anything with it via VirtualBox GUI (reset it, or close with saving state), the VB itself hangs too. The only thing I can do after that is to kill VB process.

I already reported this bug for 2.2.0 beta 2, but the beta-test forum is killed, and the bug is still present in 2.2.0 final. :-(

Attachments

VBox.log Download (99.5 KB) - added by CaptainFlint 5 years ago.
Log file
Debian Desktop-2009-04-14-12-09-45.log Download (133.2 KB) - added by asc 5 years ago.
Log file from a Network related VirtualBox lock-up.

Change History

Changed 5 years ago by CaptainFlint

Log file

comment:1 Changed 5 years ago by CaptainFlint

I also tested with 3 more guests:

  • openSUSE 10.3 - reproducable under the same conditions;
  • Ubuntu 8.10 - could not reproduce;
  • WinXP SP3 - could not reproduce.

comment:2 Changed 5 years ago by misha

  • Host type changed from other to Windows

comment:3 Changed 5 years ago by sandervl73

We've hidden the beta forum, so people report problems here. Thanks for your report.

comment:4 Changed 5 years ago by thePiet

Having the same problem here too.

Using VirtualBox 2.2.0 (headless), on a Debian Lenny host, with Debian Squeeze guests. Configured the host with two virtual interfaces using tunctl, and bridged them using brctl. Set up the guests to use bridged networking. The guests boot up, but as soon as there is some traffic, the guests completely hang.

This worked all nice with 2.1.0 (using VBoxManage modifyvm <vm> --nic1 hostif etc.).

comment:5 follow-up: ↓ 6 Changed 5 years ago by CaptainFlint

Additional information: I tested it also on WinXP Pro SP3 host, and the problem is reproduced there too.

And I forgot to mention that "intensive using of the connection" in openSUSE can be obtained by its online update function. If I try to update, the hang occurs either when checking for available updates, or when installing them.

comment:6 in reply to: ↑ 5 Changed 5 years ago by thePiet

Replying to CaptainFlint:

Additional information: I tested it also on WinXP Pro SP3 host, and the problem is reproduced there too.

And I forgot to mention that "intensive using of the connection" in openSUSE can be obtained by its online update function. If I try to update, the hang occurs either when checking for available updates, or when installing them.

"Intensive use of the connection" is downloading some package from some server. At 30KB/s everything hangs.

comment:7 Changed 5 years ago by asc

I am also seeing this problem after an upgrade to VirtualBox 2.2.0. I am running on a WinXP 32bit Host, with a Debian 32bit guest.

My symptoms are the same as reported above. The VM window completely locks up and I have to close it from the Windows from the taskbar. The main VirtualBox window continues to be responsive, however.

Executing several web request using curl (to google and yahoo) was enough to trigger the problem. I will attach my log file if that might be useful. It seems to have the same error messages as the original poster.

Changed 5 years ago by asc

Log file from a Network related VirtualBox lock-up.

comment:8 follow-ups: ↓ 9 ↓ 10 Changed 5 years ago by frank

asc, could you check if changing the network emulation from PCnet to E1000 does the problem solves for you?

comment:9 in reply to: ↑ 8 Changed 5 years ago by serveren

Replying to frank:

asc, could you check if changing the network emulation from PCnet to E1000 does the problem solves for you?

Having this and other problems with 2.2 (see ticket 3749) Changing network to server T 1000 solves nothing for poor suse guest, while debian update itself in the other window with the same emulated card. The only other difference is that debian was installed under 2.1.4

comment:10 in reply to: ↑ 8 Changed 5 years ago by asc

Replying to frank:

asc, could you check if changing the network emulation from PCnet to E1000 does the problem solves for you?

I tried changed to E1000 and it seems to be working. I have executed several curl downloads, and I am posting this from the VM. Thank you for the suggestion!

Before trying this, I also changed the network support to NAT instead of Bridge mode (with the PCnet driver) and that worked too.

comment:11 Changed 5 years ago by vor_lord

Same issue occuring: it appears that switching to e1000 has corrected the problem for me also (will continue to monitor)

comment:12 Changed 5 years ago by frank

  • Component changed from other to network/hostif

The pcnet device was fixed in version 2.2.2. serveren, do you still have the same problem when using VirtualBox 2.2.2?

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use