VirtualBox

Ticket #3653 (reopened enhancement)

Opened 5 years ago

Last modified 20 months ago

Feature request: Throttle network speed

Reported by: cinan Owned by:
Priority: major Component: network
Version: VirtualBox 4.1.2 Keywords: network speed throttle
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

Hi Throttle network speed would be great feature! My idea: Just click on Settings->Network and choose max. speed. I'm sure it's very useful if you have slow connection.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3054.

comment:2 Changed 3 years ago by fulekia

  • Status changed from closed to reopened
  • Resolution duplicate deleted

How is this a duplicate of #3054? #3054 asks for IP address white/black listing (e.g., application firewall), not throughput speed configuration. This feature request is for throughput throttling, which would be incredibly handy to do without configuring some form of packet shaping or something outside of virtual box.

Having a way to set inbound/outbound throttles at arbitrary kbps/mbps per VM would be rad. Would the current virtualization scheme allow for something like that, or would it add too much overhead and/or latency?

comment:3 Changed 3 years ago by frank

  • Version changed from VirtualBox 2.2.0 to VirtualBox 4.1.2

You are correct, I did not read the other ticket carefully enough. Limiting the network speed is on our TODO list.

comment:4 Changed 20 months ago by frank

  • Description modified (diff)

The upcoming 4.2 release will support traffic shaping for outgoing traffic.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use