VirtualBox

Ticket #3523 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

SATA (ncq?) timeouts. works, then suddenly ceases: hangs guest.

Reported by: AntrygR Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords: sata timeout hang crash
Cc: Guest type: Linux
Host type: Linux

Description

VirtualBox 2.1.4, openSUSE 11.0 host, Gentoo AMD64 guest, no guest additions yet because I haven't got far enough in the Gentoo install to be able to boot into the guest directly.

When I tried unpacking the portage tgz, it'd go for awhile ( seconds ), then suddenly hang.

The error message was timeouts, and alternated between lines ending in "ncq" and lines ending in "DRDY".

Remembering that the documentation had said that SATA shouldn't be relied-on, I tried again with a boot disk of IDE type

( lspci shows that SATA is likely to be *drastically* faster than IDE: SATA can move 8k per get/put, whereas IDE moves only a few bytes, it seems )

IDE works, but if IDE emulation is speed-crippled, and I'm needing a virtual machine for *video editing* then either I gotta get that fixed, or I gotta get that fixed, if you know what I mean.

Current Host: AMD64 x2, 1GHz, 4GB, Raptor, ext3.

Current Guest settings: 1 core ( I've no idea how to set this: NO documentation on it? ) 2560MB 128MB video CD, HD ACPI enabled IO APIC enabled AMD-V enabled 3D acceleration enabled ( at least it would be, if guest additions get installed ) VMDK 8GB ( 2GB swap, 6.whatever GB / ) ALSA/ICH PCnet-FASTIII no cereal ports 1 shared folder, that will work later when guest additions get in... no remote display.

BTW, the *reason* I'm installing Gentoo is simple:

repeated installation of MS Windows requires calling MS to explain oneself to 'em.

I don't have a phone, nor do I ever want one again ( silence is glorious -- meditation & training are much easier without being continually interrupted )

Therefore, it makes sense to discover all the bugs & blockers, and their workarounds, *before* installing the OS I *have* to run in a virtual machine.

ata1.00: status: { DRDY }

ata1.00: cmd 64/20..stuff..changes..data?../40 tag 30[increases] ncq -number- -in
out-

res 40/00:00:00:00:00...etc...00:00/00 Emask 0x4 (timeout)

ACPI shutdown hangs, of course

so killing the thing with the Big Red Switch becomes necessary...

last line displaying is

  • Stopping syslog-ng ...

Machine/Close hangs, destroying VirtualBox's windows ( the rectangles are still there, but they're blank )

using KDE to kill the machine window, now VirtualBox ( no longer blank ) says Gentoo was "aborted"

BTW, seeing AMD Athlon on a 440FX is -shudder- odd...

As an aside, SOMETHING in VirtualBox is deciding how many CPUs to present to the guest, but I can't find *any* indication of how to control that in the documentation, or through the VirtualBox.org search, and the Help section isn't a help-section, it's a Trac install that doesn't have any content except for the Trac help

( maybe it was intended that the Help section of VirtualBox.org be help for the Trac system, but if so, then where's the VirtualBox Help section? peculiar user-interface/information-design )

If someone could please document, in the manual, simply & quickly, how to set the number of presented CPUs, so one doesn't get hit with stupid Re-register Windows Or Else scenarios when one upgrades the CPU, or something?

I dearly want this project to be the most configurable, fastest, solidest, and best, so I'll help however I can, but I can't code, so pls keep any requests simple and sysadmin-ey, eh?

:)

Attachments

Gentoo x32-2009-03-10-07-08-00.log Download (35.8 KB) - added by AntrygR 5 years ago.
VirtualBox.log

Change History

Changed 5 years ago by AntrygR

comment:1 in reply to: ↑ description Changed 5 years ago by AntrygR

I just discovered that the entire tgz unpack wrote NOTHING, in that last test.

du bogon ( the directory I created for the test ) is 4k, which is the blocksize of the ext3fs in the guest.

all the files disappeared.

yet it timeouted...

comment:2 Changed 5 years ago by bsd

I have a similar (the same?) problem. I'm using Vista 64 host and Gentoo Linux 64 guest (same guest as original poster), kernel 2.6.29-gentoo-r5. Kernel initialization reaches an infinite loop of timeouts just as described:

sda:<3>ata1.00: exception Emask 0x0 SAct 0x1 SErr 0x0 action 0x6 frozen

ata1.00: cmd 60/08:00:00:00:00/00:00:00:00:00/40 tag 0 ncq 4096 in

res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)

ata1.00: status: { DRDY } ata1: hard resetting link ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300) ata1.00: configured for UDMA/133 ata1: EH complete

My reason for using SATA is this: I'm using a rawdisk vmdk, to try to boot the installation of Gentoo on my hard disk as a guest. I would like to use it both as a guest on Windows and as a stand alone OS. And my hard disk is SATA...

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.6.

comment:4 Changed 2 years ago by Olegch

I faced this issue using VBox 4.1.8 on a 64-bit Ubuntu 11.10 Oneiric host.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use