VirtualBox

Ticket #3501 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Using RDP crashes the VM

Reported by: dusty Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.1.4 Keywords: rdp
Cc: Guest type: Windows
Host type: Linux

Description

I created a guest Windows XP vm running on a host linux-2.6.26 64bit (Debian Lenny).

If I use the VM via RDP from a windows XP client after a few minutes the connection hangs or crashes and so does the vm. I've not yet reproducted the problem using rdesktop but maybe because I've not used it enough time.

Attachments

VBox.log Download (40.2 KB) - added by dusty 5 years ago.
nohup.out Download (45.6 KB) - added by mld 5 years ago.
Output from vboxheadless

Change History

comment:1 Changed 5 years ago by sunlover

Please attach VBox.log from the crashing session to this ticket (from ~/.VirtualBox/Machines/name_of_your_XP_vm/Logs).

Changed 5 years ago by dusty

comment:2 Changed 5 years ago by dusty

Here it is the attach. The server was started this way: VBoxHeadless -s name &

comment:3 Changed 5 years ago by sunlover

Thanks but are you sure that the log is from a crashed VM? I'm asking because you said "after a few minutes the connection hangs or crashes and so does the vm" but the log ends with "01:30:32.625 Guest Log: VBOXNP: DLL unloaded." which is more than an hour later than the last RDP client connection (at 00:08:41.492).

BTW, what do you do in the guest when the crash happens?

Could you provide a core dump of the crashed VboxHeadless?

comment:4 Changed 5 years ago by dusty

Actually I'm unsure at all but I found those logs in the specified folder. Do I need to enable some options to create log files and/or dumps?

comment:5 Changed 5 years ago by sunlover

You can delete all VBox.* files from the /Logs directory and then reproduce the problem and attach the new VBox.log to this ticket.

Information about core dumps can be found in  http://www.virtualbox.org/wiki/Core_dump

Also after you get the new log of a core dump for a VBox crash, please describe what lead to the crash. For example, browsing a shared folders in Windows Explorer, or opening a Web page in a web browser, etc.

comment:6 Changed 5 years ago by dusty

Here it goes a new crash, but no log file has been created, maybe this is the behavior when started with VBoxHeadless.

I try now to start the vm with VBoxManage startvm

comment:7 Changed 5 years ago by sunlover

The log file is created always. If the VM was started, the log file should be there too. A lot of information is written to the log even before the guest starts. May be you have looked at a wrong Logs directory?

comment:8 Changed 5 years ago by mld

When connecting with the rdp client in microsoft xp I very often get a crashed VM after disconnecting. The logs always end like this:

10:33:49.296 VRDP: Connection closed: 10:33:54.334 VRDP: DisableStatus timed out 5000!!! 10:33:54.334 VRDP: Logoff: MBP (xx.xx.xx.xx) build 6001. User: [theuser] Domain: [] Reason 0x0001. 10:33:54.376 VBVA: VRDP acceleration has been disabled.

I have two clients using XP that crash the VM's all the time. I have never seen a crash from the client using rdesktop 1.6.

This is on debian lenny with VB 2.1.4

Have not yet tried 2.2.0

comment:9 Changed 5 years ago by mld

Fixed formatting.

10:33:49.296 VRDP: Connection closed: 
10:33:54.334 VRDP: DisableStatus timed out 5000!!! 
10:33:54.334 VRDP: Logoff: MBP (xx.xx.xx.xx) build 6001. User: [theuser] Domain: [] Reason 0x0001. 
10:33:54.376 VBVA: VRDP acceleration has been disabled. 

Also attaching output from vboxheadless.

Changed 5 years ago by mld

Output from vboxheadless

comment:10 Changed 5 years ago by frank

This problem can only be debugging if you submit a core dump, see sunlovers comment above. If you have a core dump, feel free to contact me directly via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com.

comment:11 Changed 5 years ago by frank

We've analyzed the core dumps but so far did not found the reason for the crash yet. Have you tried if VirtualBox 3.0.6 Beta 1 has the same problem?

comment:12 Changed 5 years ago by dusty

I've been unable to replicate it on 3.0.4, if you prefer we can close the bug report and I'll reopen it in case something new shows up

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Ok, in that case I will close this bug. Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use