VirtualBox

Ticket #3494 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Audio CDs are not recognized => enable passthrough option

Reported by: wdonne Owned by:
Priority: major Component: audio
Version: VirtualBox 3.0.8 Keywords: audio cd
Cc: Guest type: other
Host type: other

Description

I have a Mac OS X 10.5.6 host with a Windows XP SP3 guest that has the guest additions installed. When I insert an audio CD it is visible in Windows Explorer, but it is not recognized as an audio CD. It says the format is unknown. There is no copy-protection on any of the CDs I tried. When the Passthrough option is on, which is normally only for writing, the CDs are recognized as audio CDs, but when opening them Explorer hangs. Windows Media Player would then show the album title, but is not able to play the CD.

Change History

comment:1 Changed 5 years ago by ataraxia

I also have this problem. Host is OS X 10.5.6 Intel, guest is Arch Linux 64-bit, and VirtualBox version is 2.1.4. Guest additions are installed and up to date.

When passthrough is off, audio CDs are not accessible by the guest at all. When passthrough is on, apps attempting to read the CD inside the guest become unresponsive.

CDs tested are known to work, do not have copy-protection, and are not in use by the host.

comment:2 Changed 5 years ago by bhamail

I see the exact same behavior with VBox 2.1.4 on Ubuntu Linux amd64 host w/ WinXP guest (not accessible w/out ATAPI passthrough, accessible w/ ATAPI passthrough but hangs apps). Any workarounds?

comment:3 Changed 5 years ago by botherguy

I have this problem on Ubuntu 9.04 64bit host and winxp 32bit guest. When I mounted Audio CD with passthrough, which cannot play in itunes and also cannot rip to AAC.

comment:5 Changed 5 years ago by dmaker

Dang, forgot to add these: host: WinXP SP3, guest: WinXP SP3.

comment:6 Changed 5 years ago by sandervl73

dmaker: the only thing you will achieve with rants like that is that we will ignore you. You have added no valuable information except insults, so I will delete your comment.

comment:7 Changed 5 years ago by dmaker

Well what do you want? I reported that this is still a problem since there have been no comments for a while. Also I reported NEW INFO, which you TOTALLY ignored; this problem persist in the new 3.0.0 version. Are you trying to sweep this under the rug? Why didn't you amend the version metadata? WHAT ELSE CAN I DO FOR YOU? I can't magically create new info which might make you fix this problem. If you don't want input from users, then fine, I'm off, delete and ignore all you want.. you know, you're a bit ingrateful, you don't want my _FREE_ help, ok, alienate your caring users, that'll do you fine.. or what do you think?

comment:8 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.1.4 to VirtualBox 3.0.0

If you want to complain, then go to the forum and vent your frustrations there. Here this is inappropriate. Stick to the facts and remain civilized.

Many people assume their problems are the most important ones and need to be addressed first. That's obviously not how things work.

We are aware of the problem, but it's hardly a blocker. We'll fix it when we get around to it. If that's not good enough for you, then that's unfortunate. Yelling will not help, so take a deep breath and calm down.

comment:9 Changed 5 years ago by TheOpenSourcerer

I can confirm this too.

Host: Ubuntu 9.04 with VBox PEUL 3.02. Guest: Windows XP SP3. Apps: iTunes on Windows

Audio CDs are visible in the XP guest with passthrough enabled. But ripping or playing audio CDs does not work.

For my requirements this is a serious issue. Will have to go back to a dual boot scenario until resolved. I am not bothered about being able to play audio CDs in a guest, the key feature is to be able to rip them using iTunes.

HTH

comment:10 Changed 5 years ago by bronger

Same for me: I switched back to dual boot, for iTunes.

Sorry for the noise, but this seems to be the only way to subscribe to a ticket.

comment:11 Changed 5 years ago by Wonderer

Could somebody update the following data:

  • Version -> 3.0.8
  • Host type -> ALL
  • Guest type -> ALL

Maybe the host type change would yield more interest towards this ticket!?

Is this ticket being discussed somewhere? Please post a link to it.

Thank you.

comment:12 Changed 5 years ago by frank

  • Host type changed from Mac OS X to other
  • Version changed from VirtualBox 3.0.0 to VirtualBox 3.0.8
  • Guest type changed from Windows to other

Fixing this ticket is low priority, sorry. There are more important bugs around.

comment:13 Changed 5 years ago by cortana

#5187 is a duplicate of this, it contains the virtualbox log if that's helpful.

comment:14 Changed 4 years ago by don.borsto

Problem still exists with 3.0.12

comment:15 Changed 4 years ago by don.borsto

Tag for search: This problem cause SonicStage hanging when trying to access Audio-CD.

comment:16 Changed 4 years ago by klaus

Just for the record: the user manual documents in section "Writing CDs and DVDs using the host drive" that the passthrough mode doesn't support audio CDs. There are no plans for changing this in the near future.

comment:17 Changed 4 years ago by don.borsto

To quote the manual correctly, the section talks about "writing features", this bug concerns reading.

The other way to close this defect is to revise the manual...

comment:18 Changed 4 years ago by klaus

That sounds very acceptable to me... will change the docs which go into 3.1.0.

comment:19 follow-up: ↓ 22 Changed 4 years ago by klaus

  • Cc werner.donne@… removed
  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from Audio CDs are not recognized to Audio CDs are not recognized => documented in 3.1.0

Extended the CD/DVD handling documentation a bit, and the missing support for audio/video CDs is clearly documented.

It would be possible to implement audio/video CD support, but the effort is in no reasonable relationship with the impact on regular users. Contributions welcome.

comment:20 Changed 4 years ago by Rastislav

Here is another person who would be interested in having this capability added. Being able to run Windows applications in a non-Windows host environment is a major use case for VirtualBox. One Windows application which I use heavily is SonicStage (there is no other SW which rips CDs to ATRAC3Plus formats), and it is a pity that I have to reboot my machine every time.

comment:21 Changed 4 years ago by jonnybiggs69

  • Status changed from closed to reopened
  • Resolution wontfix deleted

New to VirtualBox and was really happy with it until I discovered this missing bit of operability... I was using VMWare Player for quite a while but was fighting with it regularly to maintain audio output from the guest and it annoys me that it runs 3+ processes in the background regardless of whether the program is runnign or not. sysconfig etc didn't seem to help. I am using multi-media editing software in the guest on my VirtualBox machine and want to be able to access audio CD's and DVD's. Please, can this be added?

comment:22 in reply to: ↑ 19 Changed 4 years ago by pivcon

Replying to klaus:

Extended the CD/DVD handling documentation a bit, and the missing support for audio/video CDs is clearly documented.

It would be possible to implement audio/video CD support, but the effort is in no reasonable relationship with the impact on regular users. Contributions welcome.

While it is documented in the manual in the CD storage section, it is NOT documented in the Known Limitations chapter (Ch 13). Please consider listing this limitation in Chapter 13 as I think it would improve the chances users are not surprised by this issue. Where it is documented know is likely to only be seen when somebody can't get it to work, whereas most comprehensive technology people who are considering using this would likely skim known limitations prior to making a decision to use it for a particular purpose.

Thank you for a great product. I would like to see this functionality fixed as well, but understand there are other issues as well. Better 3D acceleration, 2D acceleration, and multi-virtual-processor IO performance are likely all more important.

comment:23 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from Audio CDs are not recognized => documented in 3.1.0 to Audio CDs are not recognized => enable passthrough option

Fixed in 3.2.10, but passthrough *must* be enabled.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use