VirtualBox

Ticket #3487 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

Windows Remote Desktop client fails to connect to VRDP with authentication

Reported by: nimdae Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

When enabling VRDP with authentication (external or guest), using the latest RDP client from Microsoft will fail to connect.

Host: Ubuntu 8.04 Guest: Windows XP and Vista (all versions)

The problem appears to be that the VRDP service is expecting authentication details to be sent when the client is requesting a session. However, the latest version of RDP client appears to wait for the service to request authentication and does not allow entering of authentication credentials before connection. All you can enter is the user name.

This is what is found in the log:

00:41:56.048 VRDP: New connection:
00:41:56.069 VRDP: Flags 0x0000001b
00:41:56.069 VRDP: Channel: [rdpdr] [1004]. Not supported.
00:41:56.069 VRDP: Channel: [rdpsnd] [1005]. Accepted.
00:41:56.069 VRDP: Channel: [drdynvc] [1006]. Not supported.
00:41:56.069 VRDP: Channel: [cliprdr] [1007]. Accepted.
00:41:56.163 VRDP: Client seems to be MSFT.
00:41:56.163 VRDP: Logon: xxxxxxxx (xxx.xxx.xxx.xxx) build 6001. User: [] Domain: [] Screen: 0
00:41:56.164 VRDPAUTH: User: []. Domain: []. Authentication type: [External]
00:41:58.203 VRDPAUTH: external authentication module returned 'access denied'
00:41:58.203 VRDPAUTH: Access denied.
00:41:58.203 VRDP: Connection closed:
00:41:58.203 VRDP: Logoff: xxxxxxxx (xxx.xxx.xxx.xxx) build 6001. User: [] Domain: [] Reason 0x0001.

This is debug information when attempting a connection without entering anything else:

u[], d[], p[0]
init ok
Using PAM service: vrdpauth
start ok
conv: num 1 u[] p[0]
conv: 0 returning password [0]
pam_authenticate failed 10. User not known to the underlying authentication module
vrdpauth_pam_close completed

This is debug information when entering the user name, which is all that is allowed to be entered in the client:

u[administrator], d[], p[0]
init ok
Using PAM service: vrdpauth
start ok
conv: num 1 u[administrator] p[0]
conv: 0 returning password [0]
pam_authenticate failed 7. Authentication failure
vrdpauth_pam_close completed

It does not prompt for credentials. Instead, I get the following two errors before the RDP client exits:

Your Remote Desktop session has ended.

Your network administrator might have ended the connection. Try connecting again, or
contact technical support for assistance.
Your Remote Desktop session is about to end.

This computer might be low on virtual memory. Close your other programs, and then
try connecting to the remote computer again. If the problem continues, contact your
network administrator or technical support.

As mentioned, I believe the VRDP server is expecting credentials when establishing a session, and the client does not provide them, while the client is expecting a request for credentials and disconnecting when the server does not make the request and instead ends the session.

Remote Desktop client is 6.0.6001, supporting RDP 6.1.

I didn't see much information on this, but I have this problem on multiple systems with similar fairly basic configurations.

Change History

comment:1 in reply to: ↑ description Changed 5 years ago by nimdae

I've updated to 2.2.0 and this problem persists.

comment:2 Changed 5 years ago by spidey

+1, linux host (centos5) and guest (arch), tried to connect with rdesktop (1.5 and 1.6) from osx and linux as well as RDC from osx all with the same result. Not good for headless :(.

comment:3 Changed 5 years ago by megaman5

I have the following setup with the same errors: VBox: 2.2.2 Host: Windows Server 2003 Guest: Linux Mint 6 (ubuntu clone)

Will not allow me to login, gives both error messages above.

comment:4 Changed 5 years ago by sorin

+1, I confirm the same error with host fedora fc9, guest xp configured to accept guest auth method.

comment:5 follow-up: ↓ 6 Changed 5 years ago by sunlover

You can specify a password in MS RDP 6.x client. Open 'Options', enter the username, check 'Allow me to save credentials' and press Connect button. Then the client will ask for the password later. Currently this is the only way to use username/password with VRDP server and recent MS RDP clients.

comment:6 in reply to: ↑ 5 Changed 5 years ago by cendalc

Replying to sunlover:

You can specify a password in MS RDP 6.x client. Open 'Options', enter the username, check 'Allow me to save credentials' and press Connect button. Then the client will ask for the password later. Currently this is the only way to use username/password with VRDP server and recent MS RDP clients.

I cannot connect with RDP 6.0.6001 if use authentication even when I store the credentials. I have WinXP host and guest, VirtualBox 2.2.2.

comment:7 Changed 5 years ago by gast

This was the solution for me:

 http://jkow.livejournal.com/2009/06/01/

comment:8 Changed 5 years ago by nimdae

I tried this solution with a previous version of VirtualBox and it did not work. With the updates to VRDP in VirtualBox 3.0.0, I plan to update and do some testing soon. If it's not outright fixed with the VBox update, I'll try this solution again and report back.

comment:9 Changed 4 years ago by husk

I assume this hasn't been fixed yet..... I just set up VirtualBox 3.1.2 on a XP box (host) then installed a CentOS 5.3 (client) and when trying to connect to the host using port 5050 (external authentication) using Microsoft RDC 2.01 (OSX) I keep getting "You were disconnected from the Windows-based computer". I can connect using Microsoft desktop connection on the XP host by specifying user name and password.

Since the Microsoft RDC client is the only useful way to connect to Windows from OSX this is a bit of an issue.

Any kind of ETA on the fix?

Thanks

comment:10 Changed 4 years ago by frank

Still relevant with VBox 3.1.8 / VBox 3.2.4?

comment:11 Changed 4 years ago by husk

I just downloaded 3.2.4 and VRDP with external authentication seems to work :-)

Thanks

Following is from log:

......

03:35.229 VRDP: Logon: Medusa-G5 (192.168.20.4) build 0. User: [husk-sa] Domain: [little] Screen: 0

00:03:35.230 VRDPAUTH: User: [husk-sa]. Domain: [little]. Authentication type: [External]

00:03:35.243 VRDPAUTH: external authentication module returned 'access granted'

......

I did notice that when logging into the XP box using 3389 as opposed to 5050 (5050 is the VirtualBox port) the Virtualbox screen is full screen but it is easy enough to resize.

I believe this is fixed

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

comment:13 Changed 3 years ago by piousminion

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am using VirtualBox 4.0.4 and this most certainly is not fixed. The issue is exactly as described in the first post.

comment:14 Changed 3 years ago by virtualed

piousminion, did you check  http://www.virtualbox.org/ticket/8063?

comment:15 Changed 2 years ago by klaus

  • Status changed from reopened to closed
  • Resolution set to fixed

As long as there is no new information and no reaction to question there is no other option than closing the issue again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use