VirtualBox

Ticket #3442 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

Machine.LastStateChange not updated when Guest initiates a reboot

Reported by: mjlucas Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: other
Host type: other

Description

When rebooting a VM through the guest (eg rebooting after updating Guest Additions) the Machine->LastStateChange timestamp does not get updated even though the machines does a reboot (And a state change is logged in the vbox.log Changing the VM state from 'RUNNING' to 'RESETTING').

Change History

comment:1 Changed 5 years ago by mjlucas

Any comment on this bug report?

comment:2 Changed 5 years ago by sandervl73

Still valid in more recent versions? (2.2.4 or 3.0.2)

comment:3 Changed 5 years ago by mjlucas

Yes this is still valid in 3.0.2

This can be replicated by either triggering a reboot from within the Guest, or even just doing VBoxManage controlvm <vmname> reset

The VMStateChangeTime variable does not get updated even though it goes from RUNNING to RESETTING etc as per my original bug report description. I guess the main thing I need to find out is this by design or a bug. If it is by design, can the behaviour be modified to handle this case. I would think that if a machine goes back through the BIOS then that is a machine state change big enough to warrant updating the VMStateChangeTime variable.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Resetting is a VM state but not a MachineState. See the MachineState declaration in VirtualBox.xidl.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use