VirtualBox

Ticket #3429 (closed defect: obsolete)

Opened 5 years ago

Last modified 5 months ago

Mouse clicks in host list upon booting Ubuntu 8.10 guest w/ Guest Additions

Reported by: nrvale0 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Host is Ubuntu 8.10 x86 on Lenovo Thinkpad T61p with dual-head setup. No docking station.

Guest is Ubuntu 8.10 Server x86. I've installed the Guest Additions but because this is Server (a minimal install) there's no X11 and thus the VBox video drivers were not installed.

Reproduce:

1) Boot Ubuntu guest. 2) After complete boot, click on window of Ubuntu guest. 3) Hit host key to make guest relinquish keyboard and mouse control.

Mouse clicks in the host windowing session are no longer registered even though the pointer moves as expected. The only way to fix this mouse problem is to Ctrl-Alt-Backspace the windowing session and login again.

Change History

comment:1 Changed 5 years ago by michael

Is this reproducible? I don't see this behaviour on my development system (Thinkpad T61p, only using the LCD display, Ubuntu 8.10 Desktop AMD64 host, Ubuntu 8,10 Server x86 guest, VirtualBox from current SVN). The biggest differences between our systems are the dual headedness (can you try it without?) and the fact that you have a 32bit Ubuntu installation on your host.

comment:2 Changed 5 years ago by nrvale0

Non-multihead: cannot repro.

Multihead:

  • Ubuntu Server guest: 100% repro
  • WinXP Pro guest: no repro.

So, yes, multihead figures into it.

comment:3 Changed 5 years ago by michael

Would you be able to install a second Ubuntu 8.10 Server guest without Additions and see if this still occurs? Thanks.

comment:4 Changed 5 years ago by nrvale0

This happens regardless of presence of Guest Additions. I had hoped that installing GA would make it go away. It did not.

comment:5 Changed 5 years ago by michael

By the way, are you doing dual head via RandR 1.2+ or via Xinerama?

comment:6 Changed 5 years ago by nrvale0

Xinerma configured via 'sudo nvidia-settings'.

comment:7 Changed 5 years ago by freakinhippie

I can confirm this issue as well. I'm running Xinerama dual-head also with an ATI radeon x1300 pro.

Host OS is Ubuntu 8.10 (upgraded in-place from 8.04).
Guest OS is Red Hat Enterprise Linux 5 Server (without Guest Additions installed).
VirtualBox v2.0.4 (from Ubuntu 8.10 repository).

I can provide more info if necessary.

Thanks.

comment:8 Changed 5 years ago by freakinhippie

I just found also that if I boot the guest up, then login (capturing the mouse) and issue a shutdown command, when the VM exits and the window is destroyed, the same thing happens (mouse clicks aren't registered).

comment:9 Changed 5 years ago by nrvale0

Confirmed on this end as well. The only way I've found to regain full use of the mouse is to logout/Ctrl-Alt-Backspace.

comment:10 follow-up: ↓ 12 Changed 5 years ago by michael

nrvale0: I have set up NVidia Twinview on my host system, but still no joy. I have tried it both with docking station via the digital monitor connector, and without via the VGA output. Can you think of any other possible differences in our configuration, other than that I am using the AMD 64 version of Ubuntu?

freakinhippie: is your host x86 or AMD64?

comment:11 Changed 5 years ago by nrvale0

Here's my xorg.conf for reference. There is a Screen section for each monitor although I'm not currently plugged into the 2nd monitor. Not sure how that affects the xorg.conf. Note that Xinerma is enabled.

<snip>

# nvidia-settings: X configuration file generated by nvidia-settings # nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

# xorg.conf (X.Org X Window System server configuration file) # # This file was generated by dexconf, the Debian X Configuration tool, using # values from the debconf database. # # Edit this file with caution, and see the xorg.conf manual page. # (Type "man xorg.conf" at the shell prompt.) # # This file is automatically updated on xserver-xorg package upgrades *only* # if it has not been modified since the last upgrade of the xserver-xorg # package. # # Note that some configuration settings that could be done previously # in this file, now are automatically configured by the server and settings # here are ignored. # # If you have edited this file but would like it to be automatically updated # again, run the following command: # sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

Identifier "Layout0" Screen 0 "Screen0" 0 0 Screen 1 "Screen1" RightOf "Screen0"

EndSection

Section "Module"

Load "glx"

EndSection

Section "ServerFlags"

# Removed Option "Xinerama" "1" # Removed Option "Xinerama" "0"

Option "Xinerama" "1"

EndSection

Section "Monitor"

Identifier "Configured Monitor"

EndSection

Section "Monitor"

Identifier "Monitor0" VendorName "Unknown" ModelName "IBM" HorizSync 53.2 - 63.9 VertRefresh 50.0 - 60.0

EndSection

Section "Monitor"

Identifier "Monitor1" VendorName "Unknown" ModelName "ViewSonic VA520-3" HorizSync 30.0 - 62.0 VertRefresh 50.0 - 75.0

EndSection

Section "Device"

Identifier "Configured Video Device" Driver "nvidia" Option "NoLogo" "True"

EndSection

Section "Device"

Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "Quadro FX 570M" BusID "PCI:1:0:0" Screen 0

EndSection

Section "Device"

Identifier "Device1" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "Quadro FX 570M" BusID "PCI:1:0:0" Screen 1

EndSection

Section "Screen"

Identifier "Default Screen" Device "Configured Video Device" Monitor "Configured Monitor" DefaultDepth 24

EndSection

Section "Screen"

Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "TwinView" "0" Option "metamodes" "DFP: nvidia-auto-select +0+0" SubSection "Display"

Depth 24

EndSubSection

EndSection

Section "Screen"

Identifier "Screen1" Device "Device1" Monitor "Monitor1" DefaultDepth 24 Option "TwinView" "0" Option "metamodes" "CRT: nvidia-auto-select +0+0" SubSection "Display"

Depth 24

EndSubSection

EndSection

comment:12 in reply to: ↑ 10 Changed 5 years ago by freakinhippie

Replying to michael:

..SNIP.. freakinhippie: is your host x86 or AMD64?

My system is x86. Specifically, it is an Intel Core 2 Duo.

Here is my xorg.conf file as well:

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection


Section "Device"
	Identifier	"0 Generic Video Card"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Screen		0
EndSection

Section "Device"
	Identifier	"1 Generic Video Card"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Screen		1
EndSection

Section "Monitor"
	Identifier	"First DELL 1907FP"
	Option		"DPMS"
EndSection

Section "Monitor"
	Identifier	"Second DELL 1907FP"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"First Screen"
	Device		"0 Generic Video Card"
	Monitor		"First DELL 1907FP"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier	"Second Screen"
	Device		"1 Generic Video Card"
	Monitor		"Second DELL 1907FP"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		0	"First Screen"
	Screen		1	"Second Screen" RightOf "First Screen"

	Option		"Xinerama"	"true"
EndSection

Section "DRI"
	Mode	0666
EndSection

comment:13 Changed 5 years ago by michael

Not reproducible, even when I replace my xorg.conf with yours. Most likely you have something else on your host system that is interfering with VirtualBox, probably by capturing the mouse in a messy way.

comment:14 Changed 5 years ago by freakinhippie

I've just built VirtualBox from the current subversion trunk (app reports version 2.1.53_OSE) and I still have the same problem. Could you provide some insight into what other things you're talking about that could be causing the problem? I've tested the problem immediately following desktop login (with no other applications launched) and it persists. Other than Xorg/Metacity/Nautilus, I don't know what else could be capturing the mouse.

comment:15 Changed 5 years ago by freakinhippie

I've been doing some research and found this bug mentioned here:  https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/41301 It confirms that this is not a VirtualBox bug (at least not the bug I'm experiencing). There is a work-around/trigger for the bug posted in that thread that I'll reproduce below.

nrvale0 would you try the work-around/trigger and report back? Thanks.

Work-Around/Trigger (as posted by "Mark" in another thread)

To "reset" the bug without rebooting the x server you can do the following:

alt-tab to a window (firefox is the one i usually use)
alt-space to bring up the window options menu (metacity)
select move (this binds the cursor to the center of the window)
use the arrow keys to move the window to another X session window
move the mouse
the bug should now be gone

Also, according to the other thread, this particular bug apparently has been fixed in the upstream X.org release so it just needs to trickle down to Ubuntu packages.

Michael, thank you for your assistance troubleshooting this issue.

As an aside, since I don't know if it is related to the original bug or not... I was testing what was happening in vbox using xev to attach to the virtual machine window and log the events. When the bug was triggered, X was still registering mouse movement through the VM window, except that it was registering those events when the mouse was moved over the corresponding coordinates on the opposite screen. So, if my VM screen's visible upper-left coordinates were at 340,620 on the second screen, once the bug was triggered, movement starting at those coordinates on the first screen would register the mouse movements via xev. If you'd like more info, let me know.

Thanks again.

comment:16 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use