VirtualBox

Ticket #3427 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Windows 7 Display fails -> Fixed in 3.0.0

Reported by: Hoj Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 2.2.2 Keywords: Windows 7 Display guest additions 2.1.4
Cc: Guest type: Windows
Host type: other

Description

After having installed Windows Guest Additions 2.1.4 on my Windows 7 Guest (with Windows Vista host) and after rebooting I choosed the option "Adjust Window Size". This should be no problem, but the Display didn't show up correctly. Some parts of the sreen just went black, when other colours where wrong. I don't know how to describe it better, but it just didn't work correctly. I restarted several times with different settings, but the screen still didn't display right. Then I uninstalled the Guest Additions 2.1.4 and everything was normal again. To ensure that is was a bug I tried again installing the Guest Additions 2.1.4 and resizing the Window, which brought up the same problem.

Temporary Solution: Uninstall Guest Additions 2.1.4 and install 2.1.2!

Attachments

Display fails.jpg Download (204.2 KB) - added by Hoj 5 years ago.
How the display suddenly changes.
Display fails 2.jpg Download (164.2 KB) - added by Hoj 5 years ago.
One more screenshot.
Display fails 3.jpg Download (57.5 KB) - added by Hoj 5 years ago.
Before the resizing
Display fails 4.jpg Download (90.4 KB) - added by Hoj 5 years ago.
After the resizing

Change History

comment:1 Changed 5 years ago by Lelik

Unable to reproduce thist problem. I've installed 2.1.4 additions on Windows 7 guest and can resize display with "Auto-resize Guest Display" enabled option or do "Adjust Window Size". Can you attach a screenshot with this problem and describe steps to reproduce more detailed please.

comment:2 Changed 5 years ago by attoparsec

  • Summary changed from Windows 7 Diplay fails to Windows 7 Display fails

comment:3 Changed 5 years ago by attoparsec

  • Keywords Display added; Diplay removed

comment:4 Changed 5 years ago by Hoj

Very strange. Now I tried it again, and everything went OK with the 2.1.4. Computers some times have bad moods. :-)

-CLOSE-

comment:5 Changed 5 years ago by attoparsec

  • Status changed from new to closed
  • Resolution set to worksforme

Closed upon reporter's request.

Changed 5 years ago by Hoj

How the display suddenly changes.

comment:6 Changed 5 years ago by Hoj

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I am now experiencing the same problem again with Guest Additions 2.2. After having installed them, and rebooted, it just went "wrong". This time I made a nice screenshot. It looks like the theme has been changed, but in the Control Panel, everything check out fine. It has definitively something to do with the resizing of the display and the guest additions.

Changed 5 years ago by Hoj

One more screenshot.

Changed 5 years ago by Hoj

Before the resizing

Changed 5 years ago by Hoj

After the resizing

comment:7 Changed 5 years ago by Hoj

OK, after trying many different things, I gave up, uninstalled and installed 2.1.4. Then it worked again. This is quite bad and has already cost me much of my time. I hope that you will find out what it is that is wrong. Thank you.

comment:8 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.1.4 to VirtualBox 2.2.2

comment:9 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from Windows 7 Display fails to Windows 7 Display fails -> Fixed in 3.0.0

The problem should be fixed in VBox 3.0.0. You should also update the guest additions to 3.0.0. Let me know if 3.0.0 works for you. Thanks.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use