VirtualBox

Ticket #3407 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

probable bug in real mode video BIOS => Fixed in SVN/3.1.4

Reported by: Ninho Owned by:
Priority: minor Component: other
Version: VirtualBox 3.0.6 Keywords: video BIOS
Cc: Guest type: other
Host type: Linux

Description

Most probably a bug in the real mode video BIOS (int 10h).

Problem, as observed in plain MS-DOS - no ANSI.SYS or similar - running command.com or other plain text mode programs with screen scrolling :

Normally while scrolling the screen up by one line, character attributes from the bottom line (usually line 25) are reinjected to the new bottom line which is "scrolled in". After 25 (or whichever # lines on screen) lines have been scrolled, all displayed lines will have the same attributes.

However using DOS in virtualbox, the lines inserted at screen bottom invariably come with default grey on black attribute (07) !

I have not investigated code used by (in the example) command.com at instruction level, but since the 'right' behaviour I've been seing on all real machines (for almost 30 years!) and only virtualbox exhibits a difference, it has to be a bug in, most probably, the provided video BIOS.

Change History

comment:1 Changed 5 years ago by Ninho

New comment : just checked the latest video Bios used by the Bochs distibution has the same bug (i.e. 'BIOS-bochs-latest'). Good old 'BIOS-bochs-legacy' is however correct.

Are you perhaps sharing that buggy code ?

comment:2 Changed 5 years ago by Ninho

(bump!) Just updated to Virtual Box 3.06 : it appears nothing has changed.

Can we hope for a revised BIOS anytime soon ? Is this bug assigned to somebody at least ?

Regards...

comment:3 Changed 5 years ago by frank

Well, I can assign the bug to you... Contributions are always welcome.

comment:4 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.1.2 to VirtualBox 3.0.6

comment:5 Changed 4 years ago by frank

  • Summary changed from probable bug in real mode video BIOS to probable bug in real mode video BIOS => Fixed in SVN/3.1.4

This bug will be finally fixed with the next VBox maintenance release.

comment:6 Changed 4 years ago by sandervl73

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:7 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use