VirtualBox

Ticket #3404 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

date information corrupted on files ending in 'inp'

Reported by: asynchronous13 Owned by:
Priority: major Component: shared folders
Version: VirtualBox 2.1.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

From within the Guest OS (WinXP), if a file that ends in 'inp' is created/renamed/modified in a shared directory then the date information on that file is mangled.

For example, a file named 'test.inp' and a file named 'testinp' both exhibit this behavior. However, there is no problem with a file named 'inp.txt'

From the Guest, the date of the file appears to be "Thursday, July 21, 2185, 6:34:33 PM" From the Host, the date of the file appears to be "2185-07-21 19:34" (In some cases, the date has appeared as May 1913, however this is not consistent and may involve some other program operating on the file after the date is corrupted)

If a file that ends in 'inp' already exists in the shared directory, then its date is not modified. However, an 'inp' file that is created in the Host OS while the Guest OS is running will be modified when the Guest OS refreshes its file view.

The behavior is consistent and repeatable.

Attachments

WinXP-2009-02-20-11-06-38.log Download (36.8 KB) - added by asynchronous13 5 years ago.
Log File
VBoxSF.sys Download (190.7 KB) - added by frank 5 years ago.
VBoxSF.sys replacement for VirtualBox 2.2.4 guests

Change History

Changed 5 years ago by asynchronous13

Log File

Changed 5 years ago by frank

VBoxSF.sys replacement for VirtualBox 2.2.4 guests

comment:1 Changed 5 years ago by frank

I've attached a replacement for c:\windows\system32\drivers\vboxsf.sys. Could you replace this driver in your guest and check if the problem is gone?

comment:2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use