VirtualBox

Ticket #3393 (new defect)

Opened 5 years ago

Last modified 5 years ago

Vbox in WinXPSP2 does not see my USB device

Reported by: Udmek Owned by:
Priority: major Component: USB
Version: VirtualBox 2.1.4 Keywords: usb not work cannot can't add doesn't see
Cc: Guest type: Windows
Host type: Windows

Description

Can't use usb devices in guest. When trying to add a device to filters by Settings-USB-"Add filter from device", there's a greyed out <no available devices> there, although the device (USB flash stick OR bluetooth dongle) is connected. Tried adding a filter manually by Vendor ID, then starting guest. In bottom right corner, a right click on USB icon showed the same <no available devices>. When installing vbox I did choose the usb component and I did reboot after install. Thank you for your time

Attachments

VBox.zip Download (9.0 KB) - added by Udmek 5 years ago.
log

Change History

Changed 5 years ago by Udmek

log

comment:1 Changed 5 years ago by erstazi

This seems to be a duplicate of #1045.

comment:2 Changed 5 years ago by Udmek

No it's not. That one is similar but not the same. That guy/girl receives messages about device being busy. The devices stop working on the host until reboot. None of these are in my case. VirtualBox just doesn't list the devices in GUI or vboxmanage.exe. "vboxmanage.exe list hostusb" outputs - <none>. But I finally managed to solve the problem, first I tried installing SP3, the problem persisted, tried older versions of virtualbox, the same. But when I reinstalled the host usb controller drivers, everything became ok. I wonder why it broke and how often this will happen...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use