VirtualBox

Ticket #3355 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Install of FreeBSD 7.1 in a virtual machine (Mac host) fails

Reported by: mauroj Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: BSD
Host type: Mac OS X

Description

Can not install FreeBSD 7.1 in a VirtualBox 2.1.2 virtual machine, Mac OS X 10.5.6 is the host system (15" MacBook Pro, 2.33Ghz Intel Core 2 Duo). I am able to boot from the FreeBSD DVD and complete the pre-installation steps. The failure occurs during the actual installation, when packages and files are being read from the install ISO image to the virtual hard drive. I tried to install several times, building a new virtual hard disk each time. The failures occur at different places during the installation, but typically only takes a few minutes into the install. The symptom is the install just hangs - no forward progress is made, no error messages, it just stops copying files and installing packages.

Note that I was able to install FreeBSD into a Virtual Machine on the same system, from the same ISO image, using VMware Fusion, so it appears to be a bug in VirtualBox. Note also that I have OpenSolaris 2008.11 running in a VirtualBox VM jsut fine.

Change History

comment:1 Changed 5 years ago by djrobx

I see the the symptoms trying to install the latest PFsense 1.2.2 LiveCD (FreeBSD 7.1 based) under Windows. Each time you attempt to install, it will fail at different points. One time I got through the install successsfully, but it gave an error executing bash upon boot.

It appears to be corrupting data written to the virtual disk.

comment:2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Retry with 2.1.4 and reopen if necessary. That version includes several fixes for FreeBSD guests.

comment:3 Changed 5 years ago by djrobx

  • Status changed from closed to reopened
  • Resolution fixed deleted

I was attempting to install PFSense (FreeBSD 7.1) under 2.1.4 for Windows. So the problem does not appear to be solved.

comment:4 Changed 5 years ago by rjsdg

I attempt to install FreeBSD and PC BSD latest stable releases as guests in MAC OS 10.5 host. Gives me errors during installation when packages are being written to the VM filesystem. It seems that the freebsd FS it's not fully supported for MAC OS VBox.

Is there a date for the fix?

Thanks in advance!

comment:5 Changed 4 years ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to fixed

Please check with the latest 3.2 release and make sure to turn of the host I/O cache.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use