VirtualBox

Ticket #3317 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

VT-x defect with windows 3.11, 95, 98 guest

Reported by: slimjim8094 Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 2.1.2 Keywords: vt-x, vtx windows, crash, first boot
Cc: Guest type: Windows
Host type: Linux

Description

With (at least) Windows 3.11 (workgroups), Windows 95, and Windows 98, the first-boot (and subsequent boots) fail without error if VT-x is enabled. Specificlly, Windows 3.11 experiences severe (unusable) graphics corruption.

Without VT-x, these all work fine.

Linux x86-64 host with a Core2 Duo. Windows XP, Vista, 2k3, 2k8, 7, Linux guests all work fine with VT-x enabled. Nothing specific in the log file.

Untested on x86 linux host, windows host, amd, etc.

Attachments

VBox.log Download (54.9 KB) - added by johang 4 years ago.
VBox.log for booting install cd, entering install program and then powering off
ash-with-vtx-hang.log Download (37.0 KB) - added by ash 4 years ago.
Fresh install of MSDOS 6.22 and Windows 3.11, VT-x turned on (Hangs upon transition into GUI)
ash-no-vtx-nohang.log Download (32.3 KB) - added by ash 4 years ago.
Fresh install of MSDOS 6.22 and Windows 3.11, VT-x turned off (Continues to next step upon transition into GUI for Windows install)

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 5 years ago by johang

x86 linux host: win98 fails with VT-x and works without it.

comment:2 in reply to: ↑ 1 Changed 5 years ago by johang

Replying to johang:

x86 linux host: win98 fails with VT-x and works without it.

It was a Core2 Duo

comment:3 Changed 5 years ago by desrt

i have the same issue. with VT-x on it locks solid on startup. without VT-x, it's fine (but slow).

i took a bootlog from windows booting up with vt-x enabled and booting with it disabled

when enabled, the bootlog ends with

LoadSuccess = msmouse.vxd

when i disable the VT-x and boot again (ie: in order to see what would come next if everything was working OK, i see):

SYSCRITINIT = VMM

so probably the thing that is crashing is the "SYSCRITINIT = VMM" part, whatever that means.

comment:4 Changed 5 years ago by desrt

oh ya, and: booting in safe mode does not help.

comment:5 Changed 5 years ago by desrt

booting the host OS in single-CPU (ie: linux 'nosmp' boot parameter) does not help either so it is unlikely to be related to the fact that enabling VT-x also allows multiple cores to be visible (unless 'nosmp' fails to disable this...)

comment:6 Changed 5 years ago by tom760

anybody figure this out or know if it worked in a previous release of virtualbox?

if it didn't work in a previous virtualbox version, i wonder if a fix could be made by using some custom bootloader in the VM. i've been wanting to learn more about the internals of the newer intel CPUs. i'll take a look and see if any registers pop out as maybe needing a small adjustment to work with 98.

comment:7 Changed 5 years ago by ash

I tried this on a Mac OS X 10.6.0 host today on a P8400 Core 2 Duo Mac Mini. Same results. Hung immediately after attempting to start the graphical mode for Windows 3.11 in the installer (after disk 2). Disabling VT-x fixed this problem.

comment:8 Changed 5 years ago by sandervl73

  • Cc vbox_trac@… removed

Try again with 3.0.8 and attach the session's VBox.log here please.

comment:9 Changed 4 years ago by Technologov

Added myself as CC on this issue.

This bug looks similar to bug #5407

-Technologov

comment:10 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Retry with 3.1.4 please. Note that no VBox.log means we can't help in any way. Marking this one as invalid until such a log file is attached.

comment:11 Changed 4 years ago by johang

  • Status changed from closed to reopened
  • Resolution invalid deleted

Still an issue with VirtualBox 3.1.6, Windows 98 guest, Slackware64 13 host.

Install program has heavy graphics corruption.

Changed 4 years ago by johang

VBox.log for booting install cd, entering install program and then powering off

Changed 4 years ago by ash

Fresh install of MSDOS 6.22 and Windows 3.11, VT-x turned on (Hangs upon transition into GUI)

Changed 4 years ago by ash

Fresh install of MSDOS 6.22 and Windows 3.11, VT-x turned off (Continues to next step upon transition into GUI for Windows install)

comment:12 Changed 4 years ago by ash

I have attached a crashing-with-VTx and not-crashing-without-VTx log that correspond to the issue I am having. Since my initial report, I have upgraded to Mac OS X 10.6.3 on the host and Virtual Box 3.1.6. I created a fresh VM to guarantee easy replication.

comment:13 Changed 4 years ago by Technologov

Duplicate of Bug #2865

comment:14 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use