VirtualBox

Ticket #3306 (closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

cant clone vdi's after upgrade to 2.1.2 on osx

Reported by: legendgamesmaster Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Hi, Just upgraded to 2.1.2 now can't clone a vdi.

I get an error suggesting I need to have a HardDisks sub directory, which doesnt exist in my OS/X install....

here is the terminal output

Caliburn:VirtualBox andywarner$ VBoxManage clonevdi "XP box.vdi" LGnew.vdi
VirtualBox Command Line Management Interface Version 2.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

[!] FAILED calling a->virtualBox->OpenHardDisk2(src, srcDisk.asOutParam()) at line 369!
[!] Primary RC  = VBOX_E_IPRT_ERROR (0x80BB0005) - Runtime subsystem error
[!] Full error info present: true , basic error info present: true 
[!] Result Code = VBOX_E_IPRT_ERROR (0x80BB0005) - Runtime subsystem error
[!] Text        = Could not get the storage format of the hard disk '/Users/andywarner/Library/VirtualBox/HardDisks/XP box.vdi' (VERR_FILE_NOT_FOUND)
[!] Component   = HardDisk2, Interface: IHardDisk2, {ed6e2525-c2fd-42a4-917a-7a9045ac9e15}
[!] Callee      = IVirtualBox, {339abca2-f47a-4302-87f5-7bc324e6bbde}
Caliburn:VirtualBox andywarner$

Here is my directory listing, I've not changed anything.

Caliburn:VirtualBox andywarner$ ls -l
total 64
drwxr-xr-x  10 andywarner  staff    340  9 Feb 20:08 Machines
drwxr-xr-x  15 andywarner  staff    510  9 Feb 14:20 VDI
-rw-------   1 andywarner  staff   3144  9 Feb 15:26 VirtualBox.xml
-rw-------   1 andywarner  staff   3350  9 Feb 14:19 VirtualBox.xml.1.3-macosx.bak
-rw-r--r--   1 andywarner  staff   1171  9 Feb 14:52 compreg.dat
-rw-r--r--   1 andywarner  staff  17591  9 Feb 19:54 xpti.dat
Caliburn:VirtualBox andywarner$ 

Im running the command from the VirtualBox directory - I'm guessing this is correct. please advise otherwise! Or do I need to change the file names?

Many Thanks.

Andy

Change History

comment:1 Changed 5 years ago by legendgamesmaster

OK, seems I need to run from the VirtualBox directory AND specify "VDI/<filename>" rather than just the <filename> to clone from and to.

Heres my updated command

Caliburn:VirtualBox andywarner$ VBoxManage clonevdi "VDI/XP box.vdi" LGnew.vdi
VirtualBox Command Line Management Interface Version 2.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Clone hard disk created in format 'VDI'. UUID: 7f2c94a8-1c86-489c-8b12-cb0f4c8686de

which, incidently, created a folder called HardDisks and created the clone within it, because I didnt put VDI/ in front of the target filename. So, is it a bug? I don't know! But Its solved now. Andy

comment:2 Changed 5 years ago by pjw1965

looks like a duplicate of #3181

comment:3 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use