VirtualBox

Ticket #3226 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 5 years ago

Store "VirtualBox.xml" in another place or don't use it anymore

Reported by: Oungawak Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

The virtual machines can't work without ".VirtualBox\VirtualBox.xml" (which contains some "keys used to check if the VMs are OK") stored in the user's folder. This way to proceed may be convenient on Linux but not on Windows because this path can't be (easily) modified and is stored by default on the system partition.

I have some ideas to solve this problem :

1) Find a way to not use this file anymore

2) Store "VirtualBox.xml" in "My Documents" (this path is user defined)

3) Store "VirtualBox.xml" in a user defined folder (like the VDI and machines files, also I think there is no need to separate theses locations, you can simply regroup all theses files in only one user defined folder)

Change History

comment:1 Changed 5 years ago by kookyman

In addition, being able to store this file with the VMs themselves would allow multi-user hosts to allow all users to have access to the VMs. Right now, stored in a users private directory (Windows Host) all users have to build their own machines.

comment:2 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #680 basically.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use