VirtualBox

Ticket #3225 (closed defect: invalid)

Opened 5 years ago

Last modified 5 years ago

VBoxAddIF not found (/usr/share/virtualbox/VBoxAddIF.sh doesn't exist) in latest version from Sun

Reported by: kevinm3574 Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Updated my FC10 box with yum today and when I restarted had to "/etc/init.d/vboxdrv setup" (as there was a kernel update). That went fine but when I tried to start my Windows VM it complained about no vbox0 interface. Sure enough, all of my vbox interfaces were gone. When I tried to run /usr/bin/VBoxAddIF to recreate them, it didn't exist...the link wasn't there and the .sh script was missing. I've since recreated the .sh script and the link and readded my vbox interfaces but this appears to be a package bugaboo in the rpm.

Change History

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

That's because host interface networking was completely redone. Those scripts are obsolete.

comment:2 Changed 5 years ago by cfox

  • Status changed from closed to reopened
  • Resolution invalid deleted

Ok, the scripts are obsolete.

I don't see anything in the documentation about how to operate this new method on a headless server. I'm not using the UI, so how am I supposed to create these interfaces now?

What is the command line equivalent of sudo VBoxAddIF vbox3 <me> br0

comment:3 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to invalid

You don't create the interfaces. Read the documentation (8.5.3). Note that this is a defect tracker and not a platform for asking questions. Don't reopen defects and use the forum in the future.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use