VirtualBox

Ticket #3217 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Crash in icmp_find_original_mbuf => Fixed in 3.1.4

Reported by: greenrd Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

VirtualBox crashed - I was trying to ping another host at the time, although the guest was unresponsive, and then crashed. (Also, I had just plugged my USB keyboard and mouse back in, if that's relevant somehow.)

Fragment from the Apple crash report (attached):

Thread 13 Crashed: 0 VBoxDD.dylib 0x1c7bcf73 icmp_find_original_mbuf + 659 1 VBoxDD.dylib 0x1c7bf301 sorecvfrom + 497 2 VBoxDD.dylib 0x1c7bc0f1 slirp_select_poll + 1393 3 VBoxDD.dylib 0x1c7b0dd1 drvNATAsyncIoThread(PDMDRVINS*, PDMTHREAD*) + 449 4 VBoxVMM.dylib 0x014b5285 pdmR3ThreadMain(RTTHREADINT*, void*) + 213 5 VBoxRT.dylib 0x01361b60 rtThreadMain + 64 (thread.cpp:641) 6 VBoxRT.dylib 0x0138b814 rtThreadNativeMain(void*) + 132 (thread-posix.cpp:193) 7 libSystem.B.dylib 0x91dc0095 _pthread_start + 321 8 libSystem.B.dylib 0x91dbff52 thread_start + 34

I am using 2.1.0 instead of 2.1.2 because of a frequently-occurring crash bug in 2.1.2. I guess I'll try to avoid pinging from the guest, to avoid this bug!

Attachments

virtualbox-crash-usb.txt Download (37.2 KB) - added by greenrd 5 years ago.
Apple crash report
VBox.log Download (45.2 KB) - added by greenrd 5 years ago.
1-XP-main-2010-02-09-13-58-34.log Download (64.3 KB) - added by SecretCode 4 years ago.

Change History

Changed 5 years ago by greenrd

Apple crash report

Changed 5 years ago by greenrd

comment:1 Changed 5 years ago by greenrd

This is an assertion failure:

786	18:14:30.871
787	18:14:30.871 !!Assertion Failed!!
788	18:14:30.871 Expression: ip0->ip_p == IPPROTO_ICMP
789	18:14:30.871 Location  : /Users/greenrd/Downloads/VirtualBox-2.1.0/src/VBox/Devices/Network/slirp/ip_icmp.c(170) icmp_find_original_mbuf

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed in 2.1.4.

comment:3 Changed 4 years ago by SecretCode

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have exactly the same symptoms - crash of vm, with data loss - and the same final messages in the log:

04:06:44.734 !!Assertion Failed!!
04:06:44.734 Expression: ip0->ip_p == IPPROTO_ICMP
04:06:44.734 Location  : /home/vbox/vbox-3.1.2/src/VBox/Devices/Network/slirp/ip_icmp.c(184) icmp_find_original_mbuf

Just a different line number - though this could be the same line of code if lines were added before it since 2.1.0.

If this is a different bug, please feel free to close and open another / ask me to open another, but it looks very similar to me.

I was running a ping because of ISP network instability - it had run continuously for hours, and I have done the same on certain previous days without such a crash. I can accept if ICMP is not 100% reliable, but not to have a vm crash with data loss.

Changed 4 years ago by SecretCode

comment:4 Changed 4 years ago by frank

  • Version changed from VirtualBox 2.1.0 to VirtualBox 3.1.2

comment:5 Changed 4 years ago by SecretCode

One thing - my crash was with different guest (Win XP) and host (Ubuntu 9.10), as well as a different VB release (3.1.2 as noted).

Should I have opened a separate bug?

comment:6 Changed 4 years ago by frank

  • Summary changed from Crash in icmp_find_original_mbuf to Crash in icmp_find_original_mbuf => Fixed in 3.1.4

No, this defect is fine. That crash should be fixed in the upcoming 3.1.4 release.

comment:7 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:8 Changed 4 years ago by SecretCode

Thanks!

Was it the same defect (a regression) or just similar?

Can you suggest a way of testing it in 3.1.4 (as a user)? I don't know what exactly caused it in the first place - possibly intermittent.

comment:9 Changed 4 years ago by frank

That bug was introduced some releases ago and that assertion was hit under certain circumstances. The assertion isn't there anymore (replaced by proper code), therefore you will not hit it again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use