VirtualBox

Ticket #3203 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Opensuse 11.1 fail bootup with Virtualbox 2.1.2 with gdmdisplay error -> unable to reproduce, possibly fixed in SVN

Reported by: aven Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.2 Keywords: gdmdisplay
Cc: Guest type: Linux
Host type: Linux

Description

I have used Virtualbox 2.1 before when I installed Opensuse 11.1 on a Ubuntu 8.10 host but I uninstalled the Opensuse install after a while. I upgraded to Virtualbox 2.1.2 and tried to reinstall Opensuse again, it started to have this gdmdisplay error.

No matter if it was with KDE or Gnome or a different host machine like Windows Vista, it gave a gdmdisplay error at startup. It did not have this error in the previous version but, Opensuse booted up fine in failsafe mode for some reason.

Attachments

Opensuse-2009-02-01-09-59-11.log Download (46.6 KB) - added by aven 5 years ago.
Opensuse Log Dump
instructions.log Download (1.7 KB) - added by aven 5 years ago.
Instructions to Reproduce the error

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by michael

Was this with or without hardware virtualisation? Could you please attach a log from a run of the VM?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 5 years ago by aven

Replying to michael:

Was this with or without hardware virtualisation? Could you please attach a log from a run of the VM?

I enabled 3D acceleration. I have a athlon xp 2200+ with a via/s3 integrated video.

Can you please tell me how I can make a log?

comment:3 in reply to: ↑ 2 Changed 5 years ago by aven

Replying to aven:

Replying to michael:

Was this with or without hardware virtualisation? Could you please attach a log from a run of the VM?

I enabled 3D acceleration. I have a athlon xp 2200+ with a via/s3 integrated video.

Can you please tell me how I can make a log?

NVM, found the logs

Changed 5 years ago by aven

Opensuse Log Dump

comment:4 Changed 5 years ago by michael

  • Summary changed from Opensuse 11.1 fail bootup with Virtualbox 2.1.2 with gdmdisplay error to Opensuse 11.1 fail bootup with Virtualbox 2.1.2 with gdmdisplay error -> unable to reproduce, possibly fixed in SVN

I was unable to reproduce this using the current development version. I tried the following: creating a new 32bit openSUSE VM with the default settings and without hardware virtualistation, host Ubuntu 8.10 64bit. I installed openSUSE from the 11.1 installation DVD, using the defaults (except for the location, where I chose Germany) and with Gnome as a desktop choice. The installation completed successfully, including the final start of the installed system. The only difference I see is that you used a 32bit host. If you can see any important differences, please point them out, otherwise I will assume that your issue has been fixed since 2.1.2 was released.

comment:5 Changed 5 years ago by aven

The problem actually arose from the release of 2.1.2 and the weird thing was that, even in both kde or in gnome, the gdmdisplay didn't work for some reason.

In the installation, I didn't actually go with default install. I made all the partitions into 1 large one with no swap or anything. I made it autologin(if that makes any difference) and I turned up the number of colors allowed to be displayed from 16 bit to 24 bit. Everything else should not really have been touched. If it doesn't work, I'll write detailed instructions of what I did exactly. BTW, I turned floppy mount off in virtualbox, enabled cd mounting and usb as well as 3d acceleration of graphics(but that doesn't seemed to have mattered).

comment:6 Changed 5 years ago by michael

How did you turn up the number of colours? And no, the 3D acceleration shouldn't be relevant, since you didn't install Additions and it is not yet supported in the Linux additions anyway.

comment:7 Changed 5 years ago by aven

The step in the configurations, I did not use auto configurations and I changed the number of colors to display in hardware configurations section.

comment:8 Changed 5 years ago by michael

Two questions: 1) did you take a look in the Xorg log (/var/log/Xorg.0.log) to see if it contained any information? 2) if you set up a second VM, does this still occur? I have a suspicion that this is an X.Org configuration issue rather than a VirtualBox one.

comment:9 Changed 5 years ago by aven

for question 1, which xorg.log are you talking about, the opensuse guest or the host.

I installed ubuntu as guest and it works flawlessly on both my windows vista host and on my ubuntu host. its just that opensuse doesn't work on either for some reason.

comment:10 Changed 5 years ago by michael

I meant Xorg.0.log on the openSUSE guest, and whether you can reproduce this issue if you install another openSUSE guest.

comment:11 Changed 5 years ago by aven

Its kinda strange but, I was able to consistently reproduce the issue many times with every opensuse reinstall. Do you require the exact setup I did from configuring Vbox all the way to what I configured and did with opensuse install? I think the problem was triggered with something I did with opensuse as guest. The weird thing is that when opensuse is started, it starts booting in console rather than with a gui even from the start. I never had these problems with the same settings before.

When I tried to view the Xorg log (/var/log/Xorg.0.log) but that file was not found and and when other than that, any command like it gave something like a gtk error "open cannot be displayed"

comment:12 Changed 5 years ago by michael

Perhaps you should try giving me detailed instructions. So far I have completely failed to reproduce this.

Changed 5 years ago by aven

Instructions to Reproduce the error

comment:13 Changed 5 years ago by aven

This was the only method I used to encounter this error, I have not tried a default install without customisations.

comment:14 Changed 5 years ago by MrX1980

Please try it with v3.0.0 again.

comment:15 Changed 5 years ago by aven

I am using 3.0.2 this time. After installation, the screen is just blank when right when it gets past the boot menu. Same configs as last time too.

comment:16 Changed 4 years ago by Technologov

I have openSUSE 11.1 guests running perfectly here.

Host: Windows 7, x64, Core 2 Q6600, VBox 3.0.10 (and 3.1.0-BETA1). VT-x = on.

Guests: openSUSE 11.1 (32+64bit, SMP) inc. Guest Additions, Network and Sound. (except 3D).

Maybe it is related to software virtualization, need to check.

-Technologov

comment:17 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem is reproducible with VBox 3.1.8. In that case attach a VBox.log file of such a VM session.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use