VirtualBox

Ticket #3200 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

running mtr in guest crashes the guest => Fixed in SVN

Reported by: stephanecharette Owned by:
Priority: critical Component: network
Version: VirtualBox 2.1.2 Keywords: mtr
Cc: Guest type: Linux
Host type: Linux

Description

VBox 2.1.2. Host is Ubuntu 8.10-64bit. Guest is Debian Etch 4 64-bit. I've tried both NAT and and host interface.

From a command-line in my guest, I run "mtr 192.168.42.99" where that IP is at the other end of a openvpn tunnel.

About 1 second after mtr starts to run, the guest completely crashes. The VBox GUI says the guest has been "aborted". I'll attach the machine log file.

I've tried the same thing with a Ubuntu 8.10 32-bit guest that is not using openvpn, and did not see the crash. On my Debian guest, it crashes 100% of the time, always about 1 second after starting the network tool mtr.

Attachments

VBox.log.2 Download (39.1 KB) - added by stephanecharette 10 years ago.
VBox.log.2
VBox.log.1 Download (39.2 KB) - added by stephanecharette 10 years ago.
VBox.log.1
VBox.log Download (39.1 KB) - added by stephanecharette 10 years ago.
VBox.log

Change History

Changed 10 years ago by stephanecharette

VBox.log.2

Changed 10 years ago by stephanecharette

VBox.log.1

Changed 10 years ago by stephanecharette

VBox.log

comment:1 Changed 10 years ago by stephanecharette

When I run "mtr 192.168.1.3" -- where that address is a local LAN address -- then everything works fine, the guest does not crash.

But when I run "mtr 192.168.42.99" -- where that address is a host on the other end of the host's openvpn tunnel -- then the guest crashes as described.

Note that ssh and sftp through the tunnel works fine. mtr seems to be the only thing to cause a crash.

OpenVPN is installed in the host when the guest is in NAT mode.

When the guest is installed in host interface mode, I turn off openvpn in the host, and instead installed openvpn within the guest. Again, I can confirm openvpn is instaled correctly since I can ssh and sftp to the various hosts through the tunnel.

comment:2 Changed 10 years ago by stephanecharette

Thanks for the e-mail, Frank. That completely fixes this problem. I can no longer repro.

comment:3 Changed 10 years ago by frank

  • Summary changed from running mtr in guest crashes the guest to running mtr in guest crashes the guest => Fixed in SVN

comment:4 Changed 10 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 2.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use