VirtualBox

Ticket #3176 (closed defect: wontfix)

Opened 5 years ago

Last modified 5 years ago

kde4daily_4.2: Plasma panel covers lower part of maximized windows -> obsolete

Reported by: vatbier Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

KDE 4.2.00 in virtual machine kde4daily in Virtualbox 2.1.2

Lower border of maximized windows in kde 4.2 should stay above plasma panel. With plasma panel set to "Always visible" the panel covers the lower part of maximized windows. The lower border of maximized windows should stay above plasma panel.

Now the info in the lower bar of konqueror(filemanager) is covered by the panel.

See  http://bugs.kde.org/show_bug.cgi?id=181675 .

Aaron Seigo thinks it's a problem of Virtualbox as KDE 4.2 doesn't have this problem when run on a real computer.

I think the manual resizing of the Virtualbox window doesn't store the correct settings for the virtual KDE 4.2.

I think it's important to look at this since every major distribution is going to release soon a Spring version with KDE 4.2 on it.

Attachments

info in lower bar of konqueror should not be covered by panel.png Download (14.8 KB) - added by vatbier 5 years ago.
this info in lower bar of konqueror should not be covered by panel
info in lower bar of maximized konquer is covered by panel.png Download (28.2 KB) - added by vatbier 5 years ago.
info in lower bar of maximized konquer is covered by panel

Change History

Changed 5 years ago by vatbier

this info in lower bar of konqueror should not be covered by panel

Changed 5 years ago by vatbier

info in lower bar of maximized konquer is covered by panel

comment:1 Changed 5 years ago by vatbier

I think the problem lies with Guest Additions.

Kde4daily with KDE 4.2 always started up in 720x400, the resolution of the startup console.
I changed kde4daily's grub menu.lst to start with "vga=791": that way the console screen is 1024x768 and KDE 4.2 starts then also in 1024x768.
In that screen size maximized windows stays nicely above the plasma panel.
But if I resize the virtualbox window to another size or go fullscreen(1280x1024), the maximized windows are covered by the panel.
I edited /etc/X11/xorg.conf of kde4daily with:
Xorg -configure :1
cp ./xorg.conf.new /etc/X11/xorg.conf
And I added the line
Modes "1280x1024" "1024x768" "800x600" "640x480"
With this I can have a usable fullscreen with good maximized windows but a bad virtualbox window as it is not possible anymore to resize the window. With systemsettings of KDE 4.2 I can change the resolution to 1024x768 but then maximized windows, for some reason, only cover half the screen.
So I've commented out the "Modes "1280x1024"..." line and my kde4daily starts back up in 1024x768.
I think nice maximized windows in KDE are only possible for the resolution of the console or for those resolutions in the "Modes" line of xorg.conf.
Guest Additions should make KDE 4.2 think that any resized resolution or fullscreen resolution is a "good" resolution so that maximized windows are not covered by the panel.

comment:2 Changed 5 years ago by vatbier

When I work with a virtualmachine I switch regularly between three resolutions:

  • kde4daily at a default 1024x768 in a Virtualbox window.
  • a maximized Virtualbox window (thus kde4daily at a resolution a few pixels less than 1280x1024).
  • a fullscreen kde4daily at 1280x1024.

It ruins my virtualmachine experience if I only can have nice maximized windows inside kde4daily at 1024x768.

comment:3 Changed 5 years ago by michael

I can't reproduce this. I take it you are talking about the VDI image linked to from  http://etotheipiplusone.com/kde4daily/docs/kde4daily.html#Where_Is_It. Can you please give me precise instructions about how to make this issue appear, if possible involving the command "VBoxManage controlvm ... setvideohint", which is the command line equivalent of resizing the window using the mouse.

I'm not convinced that this is a VirtualBox issue in any case, having seen the problems KDE 4 has in general with screen resizes via xrandr.

comment:4 Changed 5 years ago by vatbier

Sorry didn't had time to follow this up.
There are no precise instructions, my home system is Mandriva Linux 2009 with KDE 4.1.3. Virtualbox 2.1.2 with the kde4daily_4.2. Kde4daily_4.2 boots up in a 720x400 resolution. If I resize the virtualbox window with the mouse to any bigger size, any maximized windows of kde 4.2 are covered by the panel.

I will try the new VirtualBox 2.1.4 with "KDE Four Live" CD (openSUSE 11.1 ) and see if it happens there.

comment:5 Changed 5 years ago by vatbier

With new virtualbox 2.1.4 kde4daily_4.2 still has the problem.

But "KDE Four Live" CD (openSUSE 11.1) from  http://home.kde.org/~binner/kde-four-live/ with new virtualbox 2.1.4 doesn't have the problem.
When installing guest additions this message was given: "Disabling dynamic resizing as the X server is configured to only use static resolutions. To fix this, edit the server configuration file, remove all "Modes" lines from the "Screen" section and any Option "PreferredMode" lines from "Monitor" sections and restart the server."
So I did that and when I resize know the maximized windows stay above the plasma panel.

So this bug is only a problem with kde4daily_4.2 which no longer gets updates.
Bug may be closed.

comment:6 Changed 5 years ago by michael

Is this still an issue?

comment:7 Changed 5 years ago by vatbier

No. kde4daily is no longer updated. Using Kubuntu in Virtualbox 3.0.8 with KDE 4.3.2 : works ok.

comment:8 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to wontfix
  • Summary changed from kde4daily_4.2: Plasma panel covers lower part of maximized windows to kde4daily_4.2: Plasma panel covers lower part of maximized windows -> obsolete

Thanks for the feedback, I will close this ticket then.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use