VirtualBox

Ticket #3175 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

Installtion on WinXP SP3 never finishes

Reported by: berntrop Owned by:
Priority: blocker Component: installer
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Windows XP sp3 (Dutch) Virtualbox 2.06 and 2.1.0 worked fine. Tried to upgrade to 2.1.2 after 4 unsigned driver warnings, no more progress (Progress bar is full)

Also, on restart windows host hangs in boot progress screen. I got my host working again by reinstalling the network. I have retried using the settings shown in the faq, but no MSI file was generated. i include a setupapi.log

Attachments

berntrop _setupapi.rar Download (55.5 KB) - added by berntrop 5 years ago.
setupapi.log of ahlyting install
berntrop_dneinst.rar Download (8.5 KB) - added by berntrop 5 years ago.
additional dneinst.log file which shows an errror
MSI3ce9b.zip Download (38.8 KB) - added by hohokus 5 years ago.
2.2.0 r45846 -> 2.2.2 upgrade failure

Change History

Changed 5 years ago by berntrop

setupapi.log of ahlyting install

Changed 5 years ago by berntrop

additional dneinst.log file which shows an errror

comment:1 Changed 5 years ago by coloradosunsa

Tried a clean install on xp sp3 and it hung during the install. Cancel it ran over 30 min and then xp finally crashed. Tried to cleanup registry and file bits and reinstall but now it only rolls back the action every time.

comment:2 Changed 5 years ago by berntrop

An added side effect is that this completely screws the network settings for VPN solutions. I now have to reinstall my two windows machines - not funny.

comment:3 Changed 5 years ago by j

I have similar issues... not quite, but eerily similar.

  • Attempted to uninstall previous version, 2.0.6 in this case, but it hangs on every uninstall every time and I have to shutdown manually.
  • Attempted to install new 2.1.2 version and it informs me that I must reverse the previous uninstall, so then after all this I get 2 VBox versions installed at the same time.
  • Now I get BSODs with page fault in non-paged area, and RPCDOM shutdown errors. System restore does not work either!
  • After editing the registry to allow Windows Installer service to run in networked safe mode, I managed to uninstall both versions, still after multiple manual restarts though.
  • 2.1.2 does not install still, as coloadosunsa said: "it only rolls back the action every time." I reinstalled 2.0.6 for now, and it worked the first time.

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Installtion on WinXP SP3 never finishes to Installtion on WinXP SP3 never finishes -> retry with 2.1.4

Retry with 2.1.4. Several installation and network filter BSOD issues were fixed.

comment:5 follow-up: ↓ 6 Changed 5 years ago by atoponce

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopening ticket. Having the same problem with 2.2.2 on XP Pro SP3. It looks like it's in the final stages, but then just sits there.

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 9 Changed 5 years ago by misha

Replying to atoponce:

Reopening ticket. Having the same problem with 2.2.2 on XP Pro SP3. It looks like it's in the final stages, but then just sits there.

Could you attach  msi log for your hanging install?

Changed 5 years ago by hohokus

2.2.0 r45846 -> 2.2.2 upgrade failure

comment:7 follow-up: ↓ 11 Changed 5 years ago by hohokus

same problem on 2 machines, both xp sp3, attempting to upgrade from 2.2.0 -> 2.2.2. installer log attached.

comment:8 Changed 5 years ago by Riga

I had the same problem, but program had finally installed after a few attempts.

comment:9 in reply to: ↑ 6 Changed 5 years ago by atoponce

Replying to misha:

Replying to atoponce:

Reopening ticket. Having the same problem with 2.2.2 on XP Pro SP3. It looks like it's in the final stages, but then just sits there.

Could you attach  msi log for your hanging install?

Unfortunately, this is on a production machine, and I don't want to spend the time running through the headache it provided. After canceling, and restarting my machine, any and all Windows networking was broken. I had to uninstall VirtualBox to restore networking to XP. I gave it a few attempts, each with the exact same outcome. VirtualBox 2.2.2 was not finishing the install, and rebooting the machine left me without networking. 2.2.0 finished the install promptly, and kept my networking in place.

comment:10 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.1.2 to VirtualBox 2.2.2
  • Summary changed from Installtion on WinXP SP3 never finishes -> retry with 2.1.4 to Installtion on WinXP SP3 never finishes

comment:11 in reply to: ↑ 7 Changed 5 years ago by misha

Replying to hohokus:

same problem on 2 machines, both xp sp3, attempting to upgrade from 2.2.0 -> 2.2.2. installer log attached.

This is a known 2.2.0 installation issue. You need to uninstall 2.2 before installing the 2.2.2. If it fails to uninstall, please follow the instructions  here on how to uninstall it.

comment:12 Changed 5 years ago by ddn

Guys, i think there is some sort of issue with installer: See ticket 4489  http://www.virtualbox.org/ticket/4489

comment:13 Changed 4 years ago by Technologov

Is this still relevant for v3.1.0 ?

-Technologov

comment:14 Changed 4 years ago by dpetrov

Still a problem on some Windows XP SP3 hosts with v3.1.0.

comment:15 Changed 4 years ago by 2GooD

On the Windows XP SP2 machine I use, I am only able to install/upgrade VirtualBox when the machine is newly booted. I hope that works for you too.

comment:16 Changed 3 years ago by frank

So still relevant with VBox 3.2.10? In that case, please attach a VBox.log file of such a VM session.

comment:17 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use