VirtualBox

Ticket #3105 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Copy/paste to/from OpenSolaris 2008.11 guest doesn't work -> works in 2.2.0

Reported by: julianct Owned by:
Priority: minor Component: clipboard
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

Hi,

Since VB 2.1.0 I've been unable to use copy/paste between my Windows XP SP2 host and OpenSolaris 2008.11 (32-bit) guest. This is still the case in VB 2.1.2.

Mostly the copy/paste operations do nothing, but sometimes they will crash the host application I'm pasting into (e.g. Notepad).

If I kill and restart the VBoxClient on the guest then sometimes copy/paste starts working for a while, but generally fails after a few minutes.

I've confirmed that the 2.1.2 additions are installed and running on the OpenSolaris guest. I also tried a clean install of OpenSolaris 2008.11 in case there was any cruft left over from previous upgrades.

I've tried other guests (Windows 7 beta, Ubuntu 8.0.4) and copy/paste works fine there. Copy/paste with a Solaris 10U6 (32-bit) guest doesn't work, though.

I've attached the VBox.log from the OpenSolaris VM. I can see from it that at least the clipboard is enabled:

00:00:02.223 VBoxSharedClipboard mode: Bidirectional

Please let me know if you need any further info.

Attachments

OpenSolaris-2009-01-22-16-07-12.log Download (53.3 KB) - added by julianct 5 years ago.

Change History

Changed 5 years ago by julianct

comment:1 Changed 5 years ago by julianct

I also tested an OpenSolaris guest running under an OpenSolaris host, but see the same problem (so at least it doesn't look like a host issue).

In addition I tested Solaris Express Community Edition snv_105 as a guest, and the same problem exists there, so this does appear to be any flavour of Solaris guest...

comment:2 Changed 5 years ago by sixgig

I have also experienced intermittent problems with the clipboard in snv_106 guests. I used to have no issue with older versions of OpenSolaris (builds 95-101, i never ran builds 102-105). It seems that a restart of the application for which i am trying to copy/past into on my guest will some times solve the issue. Other times a reboot is necessary in order to get the clip board working.

An odd thing is that the clip board will work ok for a few hours, but then stop working at random (no consistent steps are taken).

If there are any debugging steps that would be helpful let me know, i would be glad to assist in any way.

comment:3 Changed 5 years ago by jimlaurent

I'm also unable to copy/paste to or from OpenSolaris 2008.11 to MacOS 10.5 host using Vbox 2.1.2.

Guest additions are installed.

comment:4 Changed 5 years ago by julianct

FTR I see the same thing with VB 2.1.4 (additions also upgraded to 2.1.4).

comment:5 Changed 5 years ago by julianct

Good news! With VB 2.2.0 and snv_111 as the guest this appears to be resolved, so please feel free to close this report.

Thanks :-)

comment:6 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Copy/paste to/from OpenSolaris 2008.11 guest doesn't work to Copy/paste to/from OpenSolaris 2008.11 guest doesn't work -> works in 2.2.0

Glad to hear it. Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use