VirtualBox

Ticket #3037 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VERR_VM_DRIVER_NOT_INSTALLED (rc=-1908)

Reported by: dkorzhevin Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I have this error, before and after i do "sudo /etc/init.d/vboxdrv setup"

Ubuntu 8.10 Kernel: Linux korg-desktop 2.6.27-11-generic #1 SMP Thu Jan 8 08:38:33 UTC 2009 i686 GNU/Linux

Attachments

VirtualBox - Error In suplibOsInit.png Download (31.4 KB) - added by dkorzhevin 5 years ago.
vbox-install.log Download (16.7 KB) - added by dkorzhevin 5 years ago.
vbox-install.log
dmesg.out Download (32.8 KB) - added by Arun 5 years ago.
dmesg output
vbox-install.2.log Download (73.9 KB) - added by Arun 5 years ago.
Install log

Change History

Changed 5 years ago by dkorzhevin

comment:1 Changed 5 years ago by frank

Please attach the file /var/log/vbox-install.log to this defect.

Changed 5 years ago by dkorzhevin

vbox-install.log

comment:2 Changed 5 years ago by grnd00

I'm running Mint v6 which is a flavor Ubuntu. I'm also getting this error.

comment:3 Changed 5 years ago by ab

i have the same problem i just update to sabayon4 kernel 2.0.6-27

comment:4 Changed 5 years ago by ab

try thiz: rmmod vboxdrv modprobe vboxdrv

comment:5 Changed 5 years ago by frank

Please could you try version 2.1.2? If this still does not work for you, please attach the vbox-install.log file again.

comment:6 Changed 5 years ago by dkorzhevin

It seems that now, after the upgrade to version 2.1.2 it works fine. Thank you very much for helping!

comment:7 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback, I will close this ticket now.

comment:8 Changed 5 years ago by Arun

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am getting same message on Oracle Enterprise Linux.

1) install.log [root@arun2 ~]# tail -15 /var/log/vbox-install.log

CC [M] /tmp/vbox.0/generic/RTLogWriteStdErr-stub-generic.o CC [M] /tmp/vbox.0/generic/RTLogWriteStdOut-stub-generic.o CC [M] /tmp/vbox.0/generic/RTLogWriteUser-generic.o CC [M] /tmp/vbox.0/generic/uuid-generic.o CC [M] /tmp/vbox.0/VBox/log-vbox.o

/tmp/vbox.0/VBox/log-vbox.c: In function `RTLogDefaultInit': /tmp/vbox.0/VBox/log-vbox.c:392: warning: ISO C90 forbids mixed declarations and code

CC [M] /tmp/vbox.0/VBox/strformat-vbox.o CC [M] /tmp/vbox.0/alloc/heapsimple.o LD [M] /tmp/vbox.0/vboxnetflt.o Building modules, stage 2. MODPOST

* Warning: "SUPDrvLinuxIDC" tmp/vbox.0/vboxnetflt.ko undefined!

CC /tmp/vbox.0/vboxnetflt.mod.o LD [M] /tmp/vbox.0/vboxnetflt.ko

2) dmesg [root@arun2 ~]# dmesg | tail -15 usb 5-1.4: new low speed USB device using address 26 input: USB HID v1.11 Mouse [USB Optical Mouse] on usb-0000:00:1a.2-1.4 sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. vboxdrv: version magic '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.2' should be '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.4' sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive. vboxdrv: version magic '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.2' should be '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.4' vboxdrv: version magic '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.2' should be '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.4' sr0: CDROM not ready. Make sure there is a disc in the drive. sr0: CDROM not ready. Make sure there is a disc in the drive.

3) I have tried with ISO and DVD, still same message

4) gcc version [root@arun2 rhel4]# gcc -v Reading specs from /usr/lib/gcc-lib/x86_64-redhat-linux/3.2.3/specs Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-cxa_atexit --enable-languages=c,c++ --disable-libgcj --host=x86_64-redhat-linux Thread model: posix gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47.3)

5) installed new gcc 3.4 and can't make it work. May be I am missing something. /opt/TWWfswbin/gcc -v Reading specs from /opt/TWWfsw/gcc343/lib/gcc/i686-pc-linux-gnu/3.4.3/specs Configured with: /opt/build/gcc-3.4.3/configure --with-included-gettext --enable-libgcj --enable-cxa_atexit --datadir=/opt/TWWfsw/gcc343/share --with-local-prefix=/opt/TWWfsw/gcc343 --prefix=/opt/TWWfsw/gcc343 Thread model: posix gcc version 3.4.3 (TWW) [root@arun2 rhel4]#

Any help will be apprecited.

comment:9 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

To compile kernel modules you have to use the same compiler which was used to compile the kernel which is actually running. If that compiler isn't available anymore, we cannot do much and this is not a bug of VirtualBox, sorry. One workaround would be to compile a new kernel with your current installed gcc (3.2), reboot and then setup the modules VBox modules again.

comment:10 Changed 5 years ago by Arun

  • Status changed from closed to reopened
  • Resolution fixed deleted

Yes, compiler is available. I have tried with old(3.2) and new (3.4).

[root@arun2 rhel4]# uname -a Linux arun2.devar.com 2.6.9-78.0.0.0.1.ELsmp #1 SMP Fri Jul 25 16:04:35 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux [root@arun2 rhel4]#

[root@arun2 rhel4]# gcc -v Reading specs from /usr/lib/gcc-lib/x86_64-redhat-linux/3.2.3/specs Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-cxa_atexit --enable-languages=c,c++ --disable-libgcj --host=x86_64-redhat-linux Thread model: posix gcc version 3.2.3 20030502 (Red Hat Linux 3.2.3-47.3)

comment:11 Changed 5 years ago by frank

Again: This is definitely a problem of your Linux distribution or at least of your installation. It does not matter which gcc versions you have installed but it does matter what gcc -v reports. For compiling the Linux kernel module, the original Linux Makefile is used. This Makefile will most likely call gcc which should map to gcc-3.4 in your case. If it does not, then fix it, probably a symlink.

comment:12 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

comment:13 Changed 5 years ago by Arun

Thanks Frank. I am not saying, it is a bug with VB. I was unable to pinpoint, it is an issue with gcc or something else. What does the logs indicate? Following 2 messages are kind of concern

1) sr0: CDROM not ready. 2) vboxdrv: version magic '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.2' should be '2.6.9-78.0.0.0.1.ELsmp SMP gcc-3.4'

By the way, I am one of Sun/MySQL support team and testing VB environment. Please let me know if another forum can help with my issue.

comment:14 Changed 5 years ago by Arun

  • Status changed from closed to reopened
  • Resolution worksforme deleted

What are main reasons to get the error? VERR_VM_DRIVER_NOT_INSTALLED (rc=-1908)

comment:15 Changed 5 years ago by frank

The reason for this error message is that the kernel driver is not found. I'm sorry but didn't I tell you in my last comment what your problem is?

Your VM will not start because the VBox kernel driver cannot be loaded. Why is the driver not loaded? Because the vboxdrv module was not correctly compiled. The messages you saw (ignore the CDROM messages, they don't matter here) indicate that the kernel refuses to load the vboxdrv kernel module because the module was compiled with the wrong compiler. The kernel expects that this module will be compiled with the same compiler as the Linux kernel. Your Linux kernel was apparently compiled with gcc-3.4 but you compiled the vboxdrv kernel module with gcc-3.2.

How to resolve this problem? Make sure that

gcc -v

reports 3.4 and that the kernel will find this gcc compiler, that is, enter just gcc without any leading path. For instance, make sure that in one of the directories which is found by the PATH variable, a symlink to /opt/TWWfsw/bin/gcc is found.

Again: gcc -v must report 3.4!

Then, recompile the kernel module with /etc/init.d/vboxdrv setup. Make sure that the output of this command does not show any error message.

After this, make sure that the kernel module is actually loaded:

lsmod|grep vboxdrv

must show the vboxdrv kernel module.

If all this works, then try to start a VM. If something does not work, please attach (there is an Attach button!) the file /var/log/vbox-install.log to this defect as well as the output of dmesg.

comment:16 Changed 5 years ago by Arun

Frank, My system is 64-bit. There was some unknown issue with gcc 64 bit and I had 32-bit sym-link to gcc. However, didn't realize both of the versions are different.

Anyway, I re-linked back to original one(64 bit).

System info:
~~~~~~~~~~~~
[root@arun2 rhel4]# more /etc/redhat-release
Enterprise Linux Enterprise Linux AS release 4 (October Update 7)

[root@arun2 rhel4]#
[root@arun2 rhel4]# uname -a
Linux arun2.devar.com 2.6.9-78.0.0.0.1.ELsmp #1 SMP Fri Jul 25 16:04:35 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@arun2 rhel4]# gcc -v
Reading specs from /usr/lib/gcc/x86_64-redhat-linux/3.4.6/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-java-awt=gtk --host=x86_64-redhat-linux
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-10.0.1)

[root@arun2 rhel4]# /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module                          [  OK  ]
Removing old VirtualBox netflt kernel module               [  OK  ]
Removing old VirtualBox kernel module                      [  OK  ]
Recompiling VirtualBox kernel module                       [  OK  ]
Starting VirtualBox kernel module                          [FAILED]
  (modprobe vboxdrv failed. Please use 'dmesg' to find out why)

[root@arun2 rhel4]#
[root@arun2 rhel4]# lsmod|grep vboxdrv
[root@arun2 rhel4]#
[root@arun2 rhel4]# dmesg > /tmp/dmesg.out

Changed 5 years ago by Arun

dmesg output

Changed 5 years ago by Arun

Install log

comment:17 Changed 5 years ago by frank

Good. Please could you read your file dmesg.out yourself and read the last 5 lines?

comment:18 Changed 5 years ago by Arun

Thanks for your patience. Now, new errors while starting new machine

The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software. (VERR_VM_DRIVER_VERSION_MISMATCH).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {e3c6d4a1-a935-47ca-b16d-f9e9c496e53e}

Here is what I did but no luck. 1) drop all VM ( configuration) 2) stopped GUI(file->exit) 3) erase RPM VirtualBox-2.1.4_42893_rhel4-1.i386.rpm 4) install RPM 5) start GUI 6) create new VM 7) start gives above error.

last few lines of dmesg:

device eth0 entered promiscuous mode bridge-eth0: enabled promiscuous mode /dev/vmnet: port on hub 0 successfully opened vboxdrv: Trying to deactivate the NMI watchdog permanently... vboxdrv: Found 4 processor cores. VBoxDrv: dbg - g_abExecMemory=ffffffffa02d1180 vboxdrv: fAsync=0 offMin=0x4e3 offMax=0x7ba5 vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'. vboxdrv: Successfully loaded version 2.1.4 (interface 0x000a0009). VBoxNetFlt: dbg - g_abExecMemory=ffffffffa0492480 /dev/vmnet: open called by PID 10813 (vmware-vmx) /dev/vmnet: port on hub 0 successfully opened

[root@arun2 rhel4]# lsmod|grep vboxdrv vboxdrv 1700524 1 vboxnetflt

comment:19 Changed 5 years ago by frank

Please: Install the amd64 package and not the x86 package. The former is for 64-bit machines, the latter for 32-bit only. amd64 is the architecture name, AMD was the inventor, it does not matter if you have an AMD CPU or an Intel CPU.

comment:20 Changed 5 years ago by Arun

My problpem is solved. You are doing excellent job of helping people. Thank you so much for helping me. I was one those who thinks AMD64 builds are meant for AMD processor. Thank you again for clarification.

Just a side note: there is only 32 bit build is available for RHEL4 and decide to go with it. Now, I end-up taking 'others' packages, which seems to create new build from scratch. Anyway, it is loading the OS now.

comment:21 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Ok, let's close this bug then, finally :-D

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use