VirtualBox

Ticket #3033 (new defect)

Opened 5 years ago

Last modified 23 months ago

USB devices not available to guest

Reported by: roadSurfer Owned by:
Priority: major Component: USB
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have tried with with and without filters and with various USB devices (IR receivers, USB sticks, TV tuners, printers) and none of them have worked. The behaviour is consistent with all device types; none are available to the guest and they are all stuck at "busy with previous request".

VB seems to capture the device (I get the Windows alert and need to install the Virtual Box USB device driver) and it shows it as captured:

UUID:               1c7853d7-0e8d-42ed-8d37-19e27836ab16
VendorId:           0x07ca (07CA)
ProductId:          0xa800 (A800)
Revision:           0.0 (0000)
Manufacturer:       AVerTV
Product:            A800
SerialNumber:       7218269C0543
Current State:      Captured

If I select the device from the VB menu (there is no tick beside it), I get a messages about it being busy:

USB device SanDisk USB U3 Cruzer with UUID [some id] is busy with a previous request. Please try again later.

Result code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {some id}
Callee: IConsole {some id} 

When I unplug and plug it back in, even with VB having focus, it will not attempt the capture and control reverts back to Windows. I also get a new entry (for an identical device) in the USB list and that shows as not captured. If I try to force it, I end up with the error "busy with previous request" message again.

"lsusb" inside Ubuntu only lists the two VB USB hubs (1.1. and 2.0), no devices. I have tried with USB 2.0 support on and off as well.

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I checked the log file and nothing seems to show, but I have attached it anyway.

One thing I have just spotted is that after a time the state of the USB device seems to change:

UUID:               1c7853d7-0e8d-42ed-8d37-19e27836ab16
VendorId:           0x07ca (07CA)
ProductId:          0xa800 (A800)
Revision:           0.0 (0000)
Manufacturer:       AVerTV
Product:            A800
SerialNumber:       7218269C0543
Address:            \?\usb#vid_80ee&pid_cafe#7218269c0543#{00873fdf-cafe-80ee-a
a5e-00c04fb1720b}
Current State:      Held

I also tried to use "VBoxManage" from the command line to attach a USB drive and part of VBox has crashed out.

Faulting application vboxsvc.exe, version 1.0.0.1, faulting module vboxddu.dll, version 0.0.0.0, fault address 0x00017864.

Attachments

VBox.log Download (52.1 KB) - added by roadSurfer 5 years ago.
USB attachement log file
VBox.2.log Download (45.6 KB) - added by elgeorge 5 years ago.
Sorry I had forgot to attach my Log, but here it is.

Change History

Changed 5 years ago by roadSurfer

USB attachement log file

comment:1 Changed 5 years ago by lpoggio

I have exactly the same behaviour with many different usb external drives and tried the same things as described in the message.

host Windows XP SP2

guest Fedora 9

The VM is capturing the USB device, as when I select the device from the VB menu the host is loosing it and the icon in the bar is disappearing.

UUID:               6ef59215-d03a-4ed9-bebd-37fcd44a8fa7
VendorId:           0x13fe (13FE)
ProductId:          0x1e23 (1E23)
Revision:           1.16 (0116)
Manufacturer:       TDK
Product:            TDK Trans-it
SerialNumber:       0700077A04940509
Current State:      Captured

If I am trying to do something else:

UUID:               6ef59215-d03a-4ed9-bebd-37fcd44a8fa7
VendorId:           0x13fe (13FE)
ProductId:          0x1e23 (1E23)
Revision:           1.16 (0116)
Manufacturer:       TDK
Product:            TDK Trans-it
SerialNumber:       0700077A04940509
Current State:      Captured

comment:2 Changed 5 years ago by mstanisz

I have the same issue with VBox 2.1.2 Running a CentOS Guest on an XP Host. I'm trying to connect a USB JTAG cable for a Xilinx board and I've tried with and without filters. Here is what I get:

USB Device 'Digilent USB JTAG Cable' with UUID {71cb4d1b-7430-4481-9b1e-f72a333e73ef} is busy with a previous request.  Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {e3c6d4a1-a935-47ca-b16d-f9e9c496e53e}

comment:3 Changed 5 years ago by roadSurfer

The problem seems to be the initial recognition of the USB device when the guest first tries to acquire it. I found these steps worked for one device, but it is crazy to need to reboot the guest just to have it recognise a USB device.

Steps (SanDisk 4gb Us datastick):
      Disable AutoRun in Windows host for the drives that the SanDisk device will appear as (it will show up as a CD drive and a removable drive).
            Do this using TweakUI from PowerToys or "gpedit.msc"*.
      Make sure the guest is not running.
      Plug the device in, allow Windows to recognise it.
      Enable USB for the guest and set up a filter for this device.
      Eject the device.
      Start guest.
      Once logged in, make sure the guest has focus and plug the device in.
      Windows will see a new device, install the VirtualBox USB driver.
      Shut guest down, eject device.
      Start guest again.
      Once logged in, make sure the guest has focus and insert the device once more.
      It should now get recognised by the guest.

comment:4 Changed 5 years ago by gsanson

I get the same problem with XP SP3 host and Centos 5 or Ubuntu 8.10 as Guest but it is with a bar code scanner. I can't see anywhere in gpedit to disable recognition of other USB devices. Does anyone have a hint or two that may help? Thanks much!

comment:5 Changed 5 years ago by kevcal

Vista Host / Mandriva guest / VirtualBox 2.1.4

I get the:

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice

messages with 'ICSI 2.0 Card Reader (011D)'

However just recently I've found that if I start the guest with the card reader inserted (no memory card in it) then the guest does detect it when I insert memory cards (shown in dmesg output) - so I have noticed some improvement recently.. I can then mount and 'dd' to/from the memory cards.

It seems to be a problem inserting (any?) usb device after the guest has started; I use a USB mouse and that's always been fine.

comment:6 Changed 5 years ago by samorrac

What roadSurfer suggests worked the first time but ... later it didn't. The host system is Vista Business.

I've discovered that what always works is:

While assuring you have defined the usb filters (vbox configuration) and the guest has the focus {
  - Plug the usb device in one usb port (vbox doesn't capture it this time)
  - Unplug the usb device. If it's a storage device in a windows host you should eject it using "safely remove hardware"
  - Plug the usb device in a usb port other than the previous one and this time ... vbox does capture it!
}

If after you have done this you need to unplug the device and plug it again you'll need to use other port different from the two previously used.

comment:7 Changed 5 years ago by na5m

This helped me: my filter for my usb printer was set to "No" for the Remote setting. after trying a million things to get my printer to work with the guest, out of desperation i changed the Remote setting to "Any". Voila! I print!

comment:8 Changed 5 years ago by hfinger

Windows XP SP3 host, VirtualBox 2.2.2, Ubuntu 9.04 Jaunty Jackalopes guest, Epson CX6900f printer/scanner/facsimile

I am experiencing exactly the same problem of 'Busy with previous request' when I try to activate the printer USB device.

Unfortunatley, I don't have the experience of other respondents and don't know where to start. With no experience of virtualisation, I found VBox a doddle to get going. It would be rather good if a virtual printer device could be specifically included in the config to set up a network/local/serial/Ethernet or whatever printer which appears as a local printer to the guest.

comment:9 Changed 5 years ago by elgeorge

Same problem here

Host
Windows Vista SP1 64 bits on Amd Turion X2 Dual-Core Mobile RM-72 2.10Ghz
Guest
Windows XP SP3 (Using default settings)
VirtualBox Version
x86/amd64 2.2.2
Device trying to plug
Lexmark P3150 (Windows Vista does not support this kind of printer)
Procedure
  1. I pluged the printer, and had to use another usb port so VBox detects it. Then I created 3 filters for the 3 drivers. E_INVALIDARG
  2. Next, I tried to clean my filters, and let just the Name. Same result.
  3. I removed the name of the 3 filters. Same result.
  4. I disabled the detected devices in the Device Manager. Same result.
Result
Result Code: E_INVALIDARG (0x80070057)
Component:   HostUSBDevice
Interface:   IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:      IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

Changed 5 years ago by elgeorge

Sorry I had forgot to attach my Log, but here it is.

comment:11 Changed 5 years ago by dboth

I am having the same basic problem with Linux host and both Linux and XP guest. Linux host is Fedora 10. I have done everything that I have found in the PDF user's guide and in the tickets and Wiki contents. I can select the USB devices and create filters for them in the VB console. But the devices are never active in the guest system, and they are always greyed out in the "Devices" menu and when selecting the USB devices icon at the bottom of the guest virtual machine screen.

This is a really important function for me and I would certainly appreciate it if you would resolve this as soon as possible.

Thanks!

comment:12 Changed 5 years ago by na5m

What do you see when you hover your mouse pointer
over the USB icon at the bottom right of the guest window?
You should see something like

Indicates the activity of the attached USB devices:
device1
device2
etc

Or, if nothing is connected, you should see

Indicates the activity of the attached USB devices:
No USB devices attached

Make sure you have the Guest Additions installed, too.
And you shouldn't Disable a device in Device Manager. VirtualBox might not detect it then.
Also, try setting Remote to Any in your filter.
Keep posting to this thread until you find an answer.


I'm running VirtualBox 2.2.2r46594 on Windows 7 (beta 7077)
with Linux guests, BSD guests, Sun guests, and Windows XP as a guest.

comment:13 Changed 5 years ago by roadSurfer

Guest Additions is installed and running. VirtualBox version is 2.2.0r45846

I brought the Ubuntu 9.04 image up on my Windows XPsp2 host. Initially there were no devices connected. Making sure the running VB image had focus, I inserted a SanDisk Cruzer U3 4GB USB drive. Windows detected new "VirtualBox" hardware and wanted install drivers. It did not need to do this as the device is already known to Windows when connected to the VB image, but I installed the drivers anyway. After the drivers had installed, the VB image still listed no USB devices as being connected. Attempting to force the USB drive connect caused an error with these details:

Result Code: 
E_INVALIDARG (0x80070057)
Component: 
HostUSBDevice
Interface: 
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: 
IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

I ejected the device and tried again, keeping the image running and with focus. It connected correctly the second time.

I unmounted the drive and control reverted to Windows from where I ejected it. VirutalBox now reported the drive as "Unknown" even though it was no longer connected. Reconnecting with VB having focus again showed the expected behaviour.

Again I unmounted the driver and control reverted to Windows. This time I attempt to grab control from the VB image by clicking on the entry in the USB list. It was connected as you would expect.

So with this USB drive, I am unable recreate the exact issue in this newer version of VB and Ubuntu. But I still see problems after the initial install of the drivers.

I then repeated these most of these steps with the AverMedia USB TV unit in the initial post (no filter was in effect, guest was not restarted).

I click on the AverMedia entry in the USB list and got the Windows request to install new drivers. Once again this should not be required as Windows is already aware of the device when connected to a VB image - but I allowed the drivers to install anyway. Once again, the guest showed that the device was not attached and an attempt to grab it returns this error:

Result Code: 
E_INVALIDARG (0x80070057)
Component: 
HostUSBDevice
Interface: 
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: 
IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}

I unplugged the AverMedia device, made sure VB had focus and plugged it back in. VB did not detect it (no filter yet). I tried to force the device connection and VirtualBox froze (even the VB console froze), forcing me to kill the process from TaskManager.

I then set-up a filter, unplugged the AverMedia device and started the VB image again. Making sure the image had focus, I plugged the AverMdeia TV device back in and it was recognised by VB. The USB icon in the lower right showed constant "chatter", but I am unable to test the device as yet.

The situation appears to have improved slightly, but as I am not testing with the same guest platform I cannot be sure where the improvement has come from. There still appear to be issues with initial installation of a USB device and in trying to dynamically take control of a USB device.

If the behaviour I have described is expected - then the documentation needs to be improved as it really is not clear on what should be done, how and when.

comment:14 Changed 5 years ago by rogue7

Host: Fedora 11 Guest: Windows XP Pro

Finally got what i needed to get usb support. It works.

1 – create a new group called “usb”; 2 – locate file usbfs: in my case is /sys/bus/usb/drivers (I suggest to find the file with a usb device inserted; 3 – modify file /etc/fstab inserting a line containing the right path and the number corresponding the “usb” group : none /sys/bus/usb/drivers usbfs devgid=503,devmode=664 0 0 4 – command mount -a; 5 – start VB and try…;

 http://www.derekhildreth.com/blog/how-to-install-virtualbox-on-fedora-10-tutorial/

comment:15 Changed 4 years ago by fatso

Still a problem. Windows 7 x64 Pro host and Ubuntu 10.04 guest (9.10 did not work either). Even with the usb devices captured with a filter I still get E_INVALIDARG (0x80070057) whenever I press the entries in the Virtualbox->Devices->Usb Devices. Have never gotten it to work.

comment:16 Changed 4 years ago by john.doe

Got the same problem after installing the "AMD USB Filter Driver" for Win7 x64 (Host) with a Lucid 10.04 guest in VBox 3.2.4. For me, simply removing the AMD Filter Driver through Software-->Remove ATI Catalyst Control Center-->Custom-->AMD USB FILTER Driver has done the trick.

Hope that helps.

comment:17 Changed 4 years ago by fatso

@John.Doe: I don't have any amd drivers or devices installed. Standard Acer Travelmate 6292 with a GMA X3100 integrated graphics solution from Intel.

comment:18 Changed 4 years ago by SSzretter

Getting the same error with a Segate 1TB external USB drive. I actually had it work ONCE, but now not at all. I have tried on two different machines - one an amd 64 quad core with windows 7, the other an amd athlon 2600 with windows xp. The guest is XP pro.

The shows in the usb pop-up, shows as captured, but hovering the usb plug it shows no devices attached.

If I select the drive, I get this error (E_INVALIDARG (0x80070057)). On the Win 7 machine I actually got an 'in use' error.

I have tried with and without a filter - added by using the green + button. Set to 'any'.

I tried setting the host bios to usb legacy off.

Any ideas???

comment:19 Changed 4 years ago by mchuck

Try adding an empty USB filter (not associated to any device) - this worked for me as suggested in Ticket #5343.

comment:20 Changed 4 years ago by SSzretter

I figured out my issue on the invalid argument machine. It is an msi mobo so I installed their driver update utility in the host. After updating 5 drivers - chipset, video,sound etc it works reliably now with the filter added with the green plus.

comment:21 Changed 3 years ago by kepler2

There are several comments in the community that VirtualBox USB support doesn't work with upper filter drivers installed on Windows hosts. I have not been able to connect USB devices to any guest after I install the AMD/ATI USB Filter Driver for SB600 series, SB700 series, and SB800 series chipsets. USB peripheral access works again after I remove the chipset USB driver. This was with VirtualBox 4.0.4 on a Windows 7 64-bit host with several Linux guests.

comment:22 Changed 3 years ago by jeinor

I have the same problem.

Host: Windows 7 64-bit Professional (SP 1) Guest: Ubuntu 11.04 64-bit Desktop VirtualBox 4.0.8 (also installed the extension pack)

I'm trying to forward my Google Nexus S phone to the VM for debugging and development of Android applications. I have added the filter for the devie (I have also tried with a "any"-filter). I can get the state to "Captured" (as other above). When I try to run the command 'lsusb' on the guest when the device is Captured, the command hangs and I have to kill the terminal. If I unplug the device, the 'lsusb' command just returns two generic usb devices. Should be easy to reproduce using any usb device, as stated above.

Just tell me if you need further information. Thanks :)

comment:23 Changed 3 years ago by Prognathous

I found a solution to the "E_INVALIDARG (0x80070057)" issue here:

 http://www.safeer.in/2009/03/virtual-box-resetting-virtual-hard_25.html

  1. Start -> Run -> CMD
  2. CD to C:\Program Files\Oracle\VirtualBox\ (or wherever you have VirtualBox installed)
  3. Run the command VBoxManage internalcommands sethduuid "FILENAME.vdi" (replace FILENAME.vdi with the .vdi file of your image)

VirtualBox developers: A nicer solution would be to replace the current dialog with something like:

"You need to set a new UUID to make this image usable."

|Set new UUID| |Cancel|

comment:24 Changed 3 years ago by michael

Prognathous: I think you may have answered the wrong ticket, as this one is about Windows host USB issues.

And regarding those issues, I would point out that Windows host USB support was reworked quite a bit for 4.1, so it might be worth checking to see if old problems have not been fixed in the process.

comment:25 Changed 3 years ago by Prognathous

Michael, I assumed that the error 0x80070057 which appears in this ticket so many times is the same issue that I had (the one that was solved using the method I quoted). If this isn't the case, then sorry for spamming.

As for v4.1, I tried it, but it didn't solve the problem.

comment:26 in reply to: ↑ description Changed 3 years ago by derf

The guy named nayasis on this forum seems to have found the solution to the problem:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=39104

It seems the registry key removal + the driver reinstallation did the trick for many of us. It worked for me.

Just follow closely the instructions, to be sure to reset properly your USB config for virtualbox.

comment:27 Changed 2 years ago by mauromol

I have this problem too. Windows 7 64-bit host. Linux Mint 10 KDE guest. Devices are captured, but they are not detected by the VM. lsusb does not show the devices. I tried to follow nayasis suggestions with care, but they didn't help. The UpperFilters in the registry was empty. I deleted it all the same, installed the VB USB filter driver manually, rebooted, unplugged my device, open and closed VB, plugged the device back, start VB and the VM, tried to check the USB device in the VB main menu. The device is "captured", but the VM doesn't see it yet. Tried with a couple of devices (an external USB drive and a webcam), with no success :-(

comment:28 Changed 2 years ago by Kohtala

I think I had this problem due to attaching device to USB 3.0 port. Moving it to USB 2.0 port made it work.

comment:29 Changed 2 years ago by Lieutenant

Same problem here, with all VirtualBox versions I tried, up to the current 4.1.12, even on different computers and different Windows versions.

On my actual computer I noticed that the problem occurs only on the two USB ports that are attached to the same root hub. It works fine on the third USB port, that uses a different host controller.

May the problem be related to root hubs?

comment:30 Changed 23 months ago by wdehoog

For my setup (Windows 7 64-bit host, Windows 32 XP guest) the problem was also that the USB devices were only listed when attached to the USB 2.0 ports. When put in a USB 3.0 port they were not listed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use