VirtualBox

Ticket #3017 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

After upgrading to 2.1.0 (Linux 64bit) network doesn't work between Host and Guests (Host interface)

Reported by: Kenjiro Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 2.1.0 Keywords: host interface
Cc: Guest type: Windows
Host type: Linux

Description

Until version 2.0.6 I could run my VMs (Windows XP, Slackware linux, Netbsd, Openbsd, etc) and make them connect to the Host OS over the network (I always used Host Interface). So I could use ssh, ftp, http, samba shares, etc from the Guest to Host (and vice versa).

Now that I upgraded to version 2.1.0 (linux 64bit) I just can't do it. It is like there is something blocking the network between Host and Guests. My firewall rules are the same before and after the upgrade, so that shouldn't be the problem. The Kernel is the same too.

It should be noted that my VMs can access my network (other computers) or the Internet. They just can't comunicate to the Host.

What can be done to fix this?

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:2 Changed 5 years ago by aleksey

Which interface on the host do you attach to? Can you get the info on vboxnetflt kernel module with 'modinfo vboxnetflt'? Can the guests obtain IP addresses via DHCP? If yes can you ping the host interface's ip address from guest?

comment:3 Changed 5 years ago by Kenjiro

@aleksey: All my "tap" interfaces (guests) are attached to the br0/eth0 of the Host (I only have one NIC on my comp).

#####

[root@coruscant:~]# modinfo vboxnetflt

filename: /lib/modules/2.6.27.7/misc/vboxnetflt.ko

version: 2.1.0 ((0xA2CDe001U))

license: GPL

description: VirtualBox Network Filter Driver

author: Sun Microsystems, Inc.

srcversion: 6F62FBEE10091C25A644C9B

depends: vboxdrv

vermagic: 2.6.27.7 SMP preempt mod_unload

#####

I don't use DHCP on my VMs. I set the IP addresses on each of them. As I said, till 2.0.6 everything worked just fine.

Please tell me if you need more info.

comment:4 Changed 5 years ago by aleksey

Can you try the latest version of vboxnetflt I attached to #3056? The instructions are there as well. It accumulates fixes for a number of issues and we'd better exclude them right from the start.

comment:5 Changed 5 years ago by Kenjiro

@aleksey

I tried that and it did work. Now I can "ping" my VMs, ssh to them, etc.

Really thanks for your attention.

comment:6 Changed 5 years ago by aleksey

  • Status changed from new to closed
  • Resolution set to fixed

The fix is included into 2.1.2. Please re-open the ticket against 2.1.2 if the problem persists.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use