VirtualBox

Ticket #3012 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VBoxManage convertdd: VERR_INVALID_PARAMETER => Fixed in SVN

Reported by: sapiency Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.0 Keywords: convertdd
Cc: Guest type: Linux
Host type: Linux

Description

host:

debian testing (current: lenny)

uname -a

Linux hostname 2.6.26-1-amd64 #1 SMP Mon Dec 15 17:25:36 UTC 2008 x86_64 GNU/Linux

source of virtualbox:

deb http://download.virtualbox.org/virtualbox/debian lenny non-free

lsusb:

ID 152d:2338 JMicron Technology Corp. / JMicron USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge

guest:

old installation, debian testing, the old system itself works properly, no damaged disk, bootable with entry in grup

what I did: connect harddisc via usb

dd if=/dev/sdb of=hda.raw

and

hostname:/vms/.VirtualBox/VDI$ VBoxManage convertdd hda.raw hda.vdi
VirtualBox Command Line Management Interface Version 2.1.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Converting from raw image file="hda.raw" to file="hda.vdi"...
Creating dynamic image with size 120034123776 bytes (114474MB)...
Error while creating the disk image "hda.vdi": VERR_INVALID_PARAMETER

Version:

hostname:/vms/.VirtualBox/VDI$ VBoxManage --version
2.1.0r41146

I do not know whether this ever makes sense:

hostname:/vms/.VirtualBox/VDI$ VBoxManage showhdinfo hda.raw
VirtualBox Command Line Management Interface Version 2.1.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

[!] FAILED calling virtualBox->OpenHardDisk2(filepath, hardDisk.asOutParam()) at line 769!
[!] Primary RC  = NS_ERROR_FAILURE (0x80004005) - Operation failed
[!] Full error info present: true , basic error info present: true 
[!] Result Code = NS_ERROR_FAILURE (0x80004005) - Operation failed
[!] Text        = Could not open the hard disk '/vms/.VirtualBox/VDI/hda.raw'.
VDI: invalid pre-header in '/vms/.VirtualBox/VDI/hda.raw' (VERR_VD_VDI_INVALID_SIGNATURE).
VD: error opening image file '/vms/.VirtualBox/VDI/hda.raw' (VERR_VD_VDI_INVALID_SIGNATURE)
[!] Component   = HardDisk2, Interface: IHardDisk2, {ed6e2525-c2fd-42a4-917a-7a9045ac9e15}
[!] Callee      = IVirtualBox, {339abca2-f47a-4302-87f5-7bc324e6bbde}

regards

reinhard

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by frank

VBoxManage showhdinfo hda.raw will show that error because the raw disk is still not converted to a .vdi file. What happens if you do

VBoxManage showhdinfo hda.vdi

comment:2 in reply to: ↑ 1 Changed 5 years ago by sapiency

Replying to frank:

VBoxManage showhdinfo hda.raw will show that error because the raw disk is still not converted to a .vdi file. What happens if you do

VBoxManage showhdinfo hda.vdi

hi,

in the meantime I converted the raw-image with 2.0.6 (running on a other installation in the virtual machine of my host ;-), which is still 2.1.0). Good news for me, it works. I think the output won't help you because it is still not possible to convert the raw-image with 2.1.0 (see output in 7th code block in my first post.

regards reinhard

comment:3 Changed 5 years ago by macias

I can confirm this. Host opensuse 11.1 64bit

virtualbox 2.1.0 -- cannot convert images 2.0.6 --> can

comment:4 Changed 5 years ago by frank

  • Summary changed from VBoxManage convertdd: VERR_INVALID_PARAMETER to VBoxManage convertdd: VERR_INVALID_PARAMETER => Fixed in SVN

Right, I missed that error. This problem is already fixed in SVN.

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use