VirtualBox

Ticket #3006 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

can't run older snapshots after upgrading to new version 2.1.0

Reported by: gmueller Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I've upgradet from last version 2.0.6 to version 2.1.0 many VMs (with active snapshots). I have tried to go back to an earlier state by discarding the snapshot. Now I can't run the machine.

VM cannot start because the saved state file '.....sav' is invalid (VERR_SSM_INTEGRITY_CRC). Discard the VM.

Errorcode: VBOX_E FILE_ERROR (ox80BB0004) component: Console Interface: IConsole {e3c6d4a1-a935-47ca-b16d-f9e9c496453e}

By the way, you can't cut and paste infos from the error window into this form.

Attachments

TEST_XP-2009-01-10-23-18-58.log Download (28.4 KB) - added by gmueller 5 years ago.

Change History

Changed 5 years ago by gmueller

comment:1 Changed 5 years ago by gmueller

Now I've discarded another snapshot and was able to start vm (with one snapshot left). Maybe I've found the reason for this behavior: I've tried to start another vm, which I've not started for a long period. I've got the same error message in the logfile:

00:00:00.814 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={e3c6d4a1-a935-47ca-b16d-f9e9c496e53e} aComponent={Console} aText={PIIX3 cannot attach drive to the Secondary Master (VERR_INVALID_PARAMETER). 546 00:00:00.814 Unknown error creating VM (VERR_INVALID_PARAMETER)} aWarning=false, preserve=false 547 00:00:00.825 Power up failed (vrc=VERR_INVALID_PARAMETER, rc=E_FAIL (0X80004005))

and realized, that the letter for the cdrom-drive has changed and therefore is not present. Maybe this was the same with two of the old snapshots, but it's annoying, that this information is kept in the snapshot?!?

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem is still reproducible with VBox 3.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use