VirtualBox

Ticket #3001 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

Chinese/Japanese characters are lost on the screen with Windows RDP client.

Reported by: JackieKu Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description (last modified by sunlover) (diff)

I encountered a problem with Windows RDP client 6.0.6001 (in XP 32bit and Vista x64). The guest OS is Windows XP SP3, while the host OS I tried Linux and Windows Vista (VirtualBox 2.0.6-2.1.0). Please see and compare the following two screen shots. The problem is some Chinese and Japanese characters are lost in some applications (eMule for example).

 Correct screen shot (WinXP native RDP server)

 Broken screen shot (VRDP)

As you can see in the second image, many text in the sidebar are disappeared. I tried all color depth and settings in the RDP client and it always occurs. Though it doesn't occur in Linux rdesktop (1.6.0) client.

Attachments

vrdp-broken.png Download (46.8 KB) - added by JackieKu 4 years ago.
VRDP (some characters are disappeared)
rdp-ok.png Download (48.9 KB) - added by JackieKu 4 years ago.
RDP (Windows native RDP server, the characters are displayed fine)

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by rickylau

Same problem here. It's seem to be the problem of Guest Additions (exists since Guest Additions v.1.6.0).

As I have virtual machines with Guest Additions 1.5.6 works fine, no matter which VirtualBox version is (1.5.6, 1.6.0, 2.0.6 and 2.1.0) But virtual machines installed Guest Additions 1.6.0 or newer (I tried 1.6.0 and 2.1.0) would display like what JackieKu?'s second screenshot in RDP.

If you found a disk image of Guest Additions version older than 1.6.0 and install it to the virtual machine the problem will be solved.

comment:2 in reply to: ↑ 1 Changed 5 years ago by JackieKu

Replying to rickylau: I confirmed it with Guest Additions 1.5.6, it doesn't have this problem. But 1.5.6 doesn't work well with current VirtualBox, so it should be fixed in latest versions.

Changed 4 years ago by JackieKu

VRDP (some characters are disappeared)

Changed 4 years ago by JackieKu

RDP (Windows native RDP server, the characters are displayed fine)

comment:3 Changed 4 years ago by JackieKu

Attach the two images as googlepages.com has been abandoned.

This bug still exists in 3.1.0.

comment:4 follow-up: ↓ 9 Changed 3 years ago by sevenstar

3 years, from version 1.6.0 to 4.1.2, this problem are still not fixed.

comment:5 follow-up: ↓ 6 Changed 2 years ago by sunlover

  • Description modified (diff)

Recently we fixed a bug in guest additions which caused text corruption in VRDP. Could you please try the following GA build and let me know if the fix help with this problem too:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.1.14-77450.iso

Thanks.

comment:6 in reply to: ↑ 5 Changed 2 years ago by JackieKu

Replying to sunlover: The problem has gone with the GA build of guest additions. Thanks.

comment:7 Changed 2 years ago by sunlover

Very good. Thanks for testing! The fix will be included in the next VBox release.

comment:8 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix included in 4.1.14.

comment:9 in reply to: ↑ 4 Changed 2 years ago by wacher

Replying to sevenstar:

3 years, from version 1.6.0 to 4.1.2, this problem are still not fixed.

hope never dies :-)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use