VirtualBox

Ticket #2991 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Cloned HD of CentOS 5.2 can not boot

Reported by: chensp Owned by:
Priority: critical Component: VM control
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

A HD cloned from another HD of CentOS 5.2 using the following:

  VBoxManage clonehd centos5.2_1.vdi centos5.2_2.vdi

can not boot up due to volume error. The cloning seems to finish successfully, but when I tried to boot the cloned HD, I got the following error on the boot screen:

  Red Hat nash version 5.1.19.6 starting
    Reading all physical volumes. This may take a while...
    No volume groups found
    Volume group "VolGroup00" not found
  Unable to access resume device (/dev/VolGroup00/LogVol01)
  mount: could not find filesystem '/dev/root'
  setuproot: moving /dev failed: no such file or directory
  setuproot: error mounting /proc: No such file or directory
  setuproot: error mounting /sys: No such file or directory
  switchroot: mount failed: No such file or directory
  Kernel panic - not syncing: Attempted to kill init!
  -

Then everything stops there forever. The original HD still can boot without problem. The cloned HD is smaller than the original one.

  Original HD:
  UUID:                 e5bcd5c4-6154-405f-a53c-46856f3482d4
  Accessible:           yes
  Logical size:         8192 MBytes
  Current size on disk: 5387 MBytes
  Type:                 normal
  Storage format:       VDI
  In use by VMs:        CentOS 5.2 (UUID: 3943ae27-f626-4e10-90b8-a9d196d180dd)

  Cloned HD:
  UUID:                 7a895493-5d70-4c68-ada8-c775084bf68b
  Accessible:           yes
  Logical size:         8192 MBytes
  Current size on disk: 4952 MBytes
  Type:                 normal
  Storage format:       VDI
  In use by VMs:        CentOS 5.2 (2) (UUID: 217d6c3e-e69b-4b5e-985c-87a073ae3135)

Host and Guest info:

Host OS: Linux Ubuntu 8.10 (x86_64) CPU: amd64

Guest OS: Linux CentOS 5.2 (i386)

Change History

comment:1 Changed 5 years ago by chensp

I tried to clone the HD another time, but got exactly the same problem. The cloned HD size is exactly the same as the previous clone.

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2813.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use