VirtualBox

Ticket #298 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

current trunk failed to build on ubuntu/AMD64 (wrong archictecture)

Reported by: pierre Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

The default architecture is wrongly redefined. x86_64 and WORDSIZE are then wrong. It tries to include stubs-32.h instead of stubs-64.h (from gnu/stubs.h).

See errors_ubuntu_amd64.txt for the exact errors. test64.c being a simple app to test these two options (works with the default arch).

Attachments

errors_ubuntu_amd64.txt Download (1.8 KB) - added by pierre 7 years ago.
test64.c Download (201 bytes) - added by pierre 7 years ago.

Change History

Changed 7 years ago by pierre

Changed 7 years ago by pierre

comment:1 Changed 7 years ago by pierre

Thanks to Klaus, I was missing the 32bit development files (libc6-dev-i386). The build went good.

I failed to get it worked on my box (amd64, ubuntu feisty) and 19 tests failed. But this bug is bogus (it may be good to add a note in a readme).

comment:2 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

comment:3 Changed 7 years ago by petroff

installing the 32 bit headers worked for me:

sudo apt-get install libc6-dev-i386
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use