VirtualBox

Ticket #2975 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

vboxnetflt does not support IPv6

Reported by: JeremyVisser Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

I am using VirtualBox 2.1.0, and am networking a VM on Host Interface mode -- my eth0 interface is selected in the VM's options, effectively bridging the VM to the network on my eth0 interface.

This works for IPv4 -- ICMP, TCP, UDP, and DHCP all work beautifully, and are properly bridged to my network.

However, any attempt to use IPv6 does not work. I can confirm that router advertisements, TCP packets, and ICMP packets are not being handled by the vboxnetflt driver on my VM, and the packets are getting nowhere.

Change History

comment:1 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:2 Changed 5 years ago by aleksey

This is rather strange. vboxnetflt works with Ethernet frames and is not particularly concerned with what is contained in them. Can you ping host's eth0 interface from guest using eth0 link-local address? I can do it in my setup (host: ubuntu 8.04, guest: ubuntu 8.10).

What are your host and guest?

comment:3 Changed 5 years ago by JeremyVisser

Host is a fully-updated Gentoo system, and guest is Ubuntu JeOS 8.04.1. I can confirm that IPv6 works perfectly if I don't use vboxnetflt, and bridge the VM to a tap0 interface instead.

comment:4 Changed 5 years ago by aleksey

Jeremy, can you try the patched file I attached to #3056? The instructions are in the comments there. This may solve the problem with IPv6 configuration.

comment:5 Changed 5 years ago by JeremyVisser

Yes! That patch fixes it! I tested with several reboots, reconfigurations, etc. before the patch, and as soon as I applied the patch, IPv6 magically started working.

Though this ticket was reported earlier, this ticket should be marked as a duplicate of #3056, as it gets to the bottom of the problem.

Thanks very much, Aleksey.

comment:6 Changed 5 years ago by aleksey

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3056 (which states the root cause of the problem).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use